Closed Bug 1442166 Opened 3 years ago Closed 2 years ago

Intermittent TEST-UNEXPECTED-PASS | font-features/kerning-spaces-arial-nokern.html != font-features/kerning-spaces-arial-default.html | image comparison, max difference: 255, number of differing pixels: 263

Categories

(Core :: Graphics: Text, defect, P5)

defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: gfx-noted)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=164741473&repo=autoland

https://queue.taskcluster.net/v1/task/Jmt_z2pHR6-S611BEkmHTg/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/Jmt_z2pHR6-S611BEkmHTg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

00:23:22     INFO -  REFTEST TEST-START | file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-nokern.html != file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-default.html
00:23:22     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-nokern.html | 43 / 67 (64%)
00:23:22     INFO -  ++DOMWINDOW == 56 (0CCC2C00) [pid = 2592] [serial = 104] [outer = 01158440]
00:23:22     INFO -  Could not create glyph run analysis.
00:23:22     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(835) : error 0x80070005: Access is denied.
00:23:22     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-default.html | 43 / 67 (64%)
00:23:22     INFO -  ++DOMWINDOW == 57 (0CCD9000) [pid = 2592] [serial = 105] [outer = 01158440]
00:23:22    ERROR -  REFTEST TEST-UNEXPECTED-PASS | file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-nokern.html != file:///Z:/task_1519776572/build/tests/reftest/tests/layout/reftests/font-features/kerning-spaces-arial-default.html | image comparison, max difference: 255, number of differing pixels: 263
Bug 1392106 strikes again. Not actually a "PASS" of this reftest as designed, but because it's a != test, the glyph that failed to render in the testcase means we do indeed get a mismatch, so it's reported as passing whereas really it's just broken.
Component: Layout: Text → Graphics: Text
Whiteboard: gfx-noted
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
New failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=171935255&repo=mozilla-central&lineNumber=22374
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.