Closed Bug 144227 Opened 19 years ago Closed 19 years ago

can't type in any text boxes after 1st browser window opened while mail is minimized

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 82534

People

(Reporter: grey, Assigned: danm.moz)

References

Details

(Whiteboard: [adt1])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020506 Netscape/7.0b1
BuildID:    2002050606

When Mozilla mail in the only component of Netscape open, then mail is minimized
and a browser window is started, all form fields are disabled.  This includes
the URL field.  You can not click in them or change them in any way.

Reproducible: Always
Steps to Reproduce:
1. Start up Mozilla mail component with no other Netscape components currently
running.
2. Minimize mail.
3. Start up a new browser window.
4. Try to click in the URL field.  Alternatively (using a bookmark) to go to a
page that contains form fields and try to click into those.

Actual Results:  After the above steps you can not click in the URL field or any
form field.  The contents can not be deleted, changed or even gain focus.

Expected Results:  The user should be able to make changes to or type in the URL
field or form fields as designed.
Cofirming....Alex and I both see this in current builds. Not sure if this is the
right owner.

Note: The user is unable to type anywhere in the browser in this state.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Form field disabled after mail minimized → can't type in any text boxes after 1st browser window opened while mail is minimized
Sounds more like editor to me ... kin?
Blocks: 143047
Keywords: nsbeta1+
Whiteboard: [adt1]
How are you starting the browser? If mail is the only thing running, and you
minimize it, where do you launch a browser window from?
I could just sucessfully reproduce on WinXP:

1. Start Netscape by double clicking on the (grey) Mail shortcut on the desktop
2. Minimize Mail
3. Click on the (green) Netscape icon to open a new browser window
4. Notice typing can not occur in URL bar nor in the home page's text (search)
boxes nor in text boxes in nsEngineer side bar

Ahhh...maybe this is our "Acrobat" bug 131007 coming back to haunt us but now
it's happening even on non-plugin pages.

Caveat: EXACTLY like in bug 131007, if you have another window open for another
application open in the background during the steps above, you can later
"unfreeze" the browser by clicking in that other application to give it focus
then clicking back to the browser to give it focus. Typing then magically works!
oh, btw, #3 was on the desktop, too :)
That is definitely events and focus, I've seen something like that before. 
joki, input?
I wonder if this is due to bug 103197.
I can confirm too.  This appears to affect only textboxes.  DOM events are 
obviously being sent to some controls, because if you set Google as your 
homepage and do this you can click the search button and you can click on 
links, as well as tab through tab stops, but you cannot click on or type in 
the textbox.  Moving to another window and back fixes the problem.
-->
Assignee: rods → kin
Oop,s per kin's comments reassinging to danm
Assignee: kin → danm
Isn't this a dup of bug 82534?

*** This bug has been marked as a duplicate of 82534 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Duplicate (sorry grey ;-))
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.