Closed Bug 144236 Opened 18 years ago Closed 16 years ago

microsoft.com - scripted popup does not load page after clicking "OK"

Categories

(Tech Evangelism Graveyard :: English US, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fago, Unassigned)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

Here is a link I was given to download a paper at Microsoft. Clicking on it
brings up a JavaScript window where you need to click "OK" to accept the
copyright. Doing so loads up the _LAST_ page you were on, and does not bring up
the paper.

This works in Konqueror.

Reproducible: Always
Steps to Reproduce:
As above

Actual Results:  Reloads last page viewed

Expected Results:  Load page I wanted
combination of two factors:

1) bad browser sniffing:
if ((document.layers) || (document.all)) {
  if (document.layers) {
     [do stuff]
  } else {
     [do other stuff]
  }
} else {
  [do more stuff]
}

2) I bet you've got popups blocked.  The javascript tries to open the file
you're after in a popup window.  It worked fine for me after I turned off popup
blocking (Win98SE, RC2)

Confirming, ->Tech evangelism to get the browser sniffing fixed
Assignee: sgehani → doron
Status: UNCONFIRMED → NEW
Component: XP Apps → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: paw → zach
Version: other → unspecified
Yes, I have "Open Unrequested Windows" unchecked, but "Open a link in a new
Window" _is_ checked. I would have assumed that this would allow such a link to
work correctly -- it usually does. 
The "OK" button is in an alert box, not within the page.  The popup is therefore
triggered by inline javascript in the page body which executes as the page loads.

As I understand it, "Open link in new window" allows windows to be opened if the
javascript is being executed as the result of a user action within the page
itself (alert boxes are kinda special)
->evang500
Keywords: evang500
Blocks: MS
Summary: Javascript does not properly load page after clicking "OK" → microsoft.com - Javascript does not properly load page after clicking "OK"
Severity: normal → minor
OS: Linux → All
Hardware: PC → All
Summary: microsoft.com - Javascript does not properly load page after clicking "OK" → microsoft.com - scripted popup does not load page after clicking "OK"
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us
works for me after adding them to the popup whitelist.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.