If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

VK_ESCAPE key message not being received in xul dialog

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
blocker
VERIFIED WORKSFORME
18 years ago
15 years ago

People

(Reporter: hangas, Assigned: joki (gone))

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When a dialog has focus on an html:select the following do not fire:

	<keyset id="keyset">
		<key keycode="VK_ENTER" oncommand="doOKButton()"/>
		<key keycode="VK_RETURN" oncommand="doOKButton()"/>
		<key keycode="VK_ESCAPE" oncommand="doCancelButton()"/>
	</keyset>

ENTER and RETURN will fire if you click on the background of dialog (outside the
html:select), and ESCAPE never fires.
(Reporter)

Updated

18 years ago
Blocks: 9635
Severity: normal → blocker
(Reporter)

Comment 1

18 years ago
Marking as blocker since 9635 is depending on this.

Updated

18 years ago
Blocks: 14742

Updated

18 years ago
QA Contact: beppe → gerardok

Updated

18 years ago
QA Contact: gerardok → claudius
(Assignee)

Updated

18 years ago
Summary: key keycode="VK_ENTER" not firing in dialog with html:select → VK_ESCAPE key message not being received in xul dialog
(Assignee)

Comment 2

18 years ago
The enter and return part of this where you have to click in the window before
the keys will work is a dupe of 9701.

The inability to get VK_ESCAPE is either a platform issue or a case of some
other event listener in the specific xul case where the event is not being
received consuming the event.  I tested on Windows and it sends a VK_ESCAPE
message just fine.

I'm going change the description to reflect that this bug will just track the
VK_ESCAPE problem (the other parts being in 9701).  I'll need either
verification that this is a platform issue or a more specific test case since
this works for me on Windows.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

18 years ago
No reponse on platform issue.  I'm getting Windows events just fine.  Since the
listed blocked bug is fixed I'm closing worksforme.  If anyone has better
platform information please reopen with test case.
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.