Crash in cubeb_enumerate_devices

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
critical
Rank:
8
RESOLVED FIXED
Last year
Last year

People

(Reporter: sylvestre, Assigned: kamidphish)

Tracking

(Blocks 1 bug, {crash})

Trunk
mozilla60
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60+ fixed)

Details

(crash signature)

Attachments

(2 attachments)

This bug was filed from the Socorro interface and is
report bp-24e6581c-889c-4e54-b667-39b8b0180302.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so cubeb_enumerate_devices media/libcubeb/src/cubeb.c:591
1 libxul.so audioipc_server::{{impl}}::process third_party/rust/cubeb-core/src/context.rs:128
2 libxul.so futures::future::{{impl}}::poll<futures::future::map_err::MapErr<audioipc::rpc::driver::Driver<audioipc::rpc::server::ServerHandler<audioipc_server::CubebServer>>, closure>> media/audioipc/audioipc/src/rpc/server.rs:117
3 libxul.so tokio_core::reactor::Core::poll third_party/rust/futures/src/future/mod.rs:106
4 libxul.so tokio_core::reactor::Core::run<futures::sync::oneshot::Receiver<>> third_party/rust/tokio-core/src/reactor/mod.rs:249
5 libxul.so std::sys_common::backtrace::__rust_begin_short_backtrace<closure, > media/audioipc/audioipc/src/core.rs:81
6 libxul.so alloc::boxed::{{impl}}::call_box<, closure> src/libstd/thread/mod.rs:406
7 libxul.so std::sys::unix::thread::{{impl}}::new::thread_start src/liballoc/boxed.rs:825
8 libpthread-2.26.so libpthread-2.26.so@0x7519 
9 libc-2.26.so libc-2.26.so@0xf53ee 

=============================================================


I was trying to watch a video https://www.youtube.com/watch?v=3tkmX9-0c94
(safe for work)
about:support makes me crash too.
Paul, rings a bell?
Flags: needinfo?(padenot)
Dan, looks like cubeb has not been initialized, or that the initialization has fail.

Sylvestre, does flipping `cubeb.sandbox.enabled` seem to "fix" the issue for you? It's not really a fix, but maybe allows sidestepping the problem.
Flags: needinfo?(sledru)
Flags: needinfo?(padenot)
Flags: needinfo?(dglastonbury)
Yeah, fixes my issue and I can even play the video (it wasn't starting before)
Flags: needinfo?(sledru)
This is causing firefox to be unusable on Linux (at least with configuration similar to mine)
Posted file about:support
on the request of Mr Adenot.
More:
$ LANG=C pactl list
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

$ pulseaudio --version
pulseaudio 11.1

$ MOZ_LOG="cubeb:4" ./firefox -p default
[12962:Main Thread]: D/cubeb Starting cubeb server...
WebGL(0x7f05712c1000)::ForceLoseContext
WebGL(0x7f056936a800)::ForceLoseContext
[12962:Main Thread]: I/cubeb media.cubeb.sandbox: true
ExceptionHandler::GenerateDump cloned child 13160
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[Child 13020, Chrome_ChildThread] WARNING: pipe error (3): Connexion ré-initialisée par le correspondant: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
(In reply to Sylvestre Ledru [:sylvestre] from comment #6)
> More:
> $ LANG=C pactl list
> Connection failure: Connection refused
> pa_context_connect() failed: Connection refused

Does this mean you have pulse installed but the server isn't configured?  I'd like to be able to reproduce locally to test out the code.

Do you still have problem in cubeb_enumerate_devices() after Bug 1441588 landed?
Assignee: nobody → dglastonbury
Flags: needinfo?(dglastonbury) → needinfo?(sledru)
OK. I reproduced the about:support crash. This is different to Bug 1441588.
Flags: needinfo?(sledru)
P1 based on comment 4.
Rank: 8
Priority: -- → P1
Comment on attachment 8955995 [details]
Bug 1442640 - Vendor in cubeb-core v0.4.4

https://reviewboard.mozilla.org/r/224938/#review231022
Attachment #8955995 - Flags: review?(giles) → review+
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a8eda5845d7
Vendor in cubeb-core v0.4.4 r=rillian
https://hg.mozilla.org/mozilla-central/rev/0a8eda5845d7
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1441596
You need to log in before you can comment on or make changes to this bug.