Closed Bug 1442679 Opened 2 years ago Closed 2 years ago

browser.tabs.insertAfterCurrent breaks browser.bookmarks.openInTabClosesMenu behavior

Categories

(Firefox :: Tabbed Browser, defect, P1)

60 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: u601173, Assigned: mixedpuppy)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180206200532

Steps to reproduce:

enable
browser.bookmarks.openInTabClosesMenu
browser.tabs.insertAfterCurrent

open a bookmark folder
tabs are opened in reverse order

Just flip browser.tabs.insertAfterCurrent to false
and it is ok

But that pref is very handy and should not break browser.bookmarks.openInTabClosesMenu
Bob, could you please take a look?
Blocks: 1344749
Component: Untriaged → Tabbed Browser
Flags: needinfo?(bob.silverberg)
Keywords: regression
Priority: -- → P2
Summary: Bug 1344749 - Expose API to customize where new tabs open breaks Bug 1420749 → browser.tabs.insertAfterCurrent breaks browser.bookmarks.openInTabClosesMenu behavior
Version: 58 Branch → 60 Branch
Blocks: 1442843
No longer blocks: 1442843
fixed by backout
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bob.silverberg)
Resolution: --- → FIXED
Assignee: nobody → bob.silverberg
Target Milestone: --- → Firefox 60
bug 1344749 comment 168 indicates this is a problem.
Assignee: bob.silverberg → mixedpuppy
Status: RESOLVED → REOPENED
Ever confirmed: true
Priority: P2 → P1
Resolution: FIXED → ---
Comment on attachment 8965376 [details]
Bug 1442679 - fix insertAfterRelated for bulk opening via tabbrowser.loadTabs,

https://reviewboard.mozilla.org/r/234112/#review240872
Attachment #8965376 - Flags: review?(dao+bmo) → review+
Pushed by mixedpuppy@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d34178082ca8
fix insertAfterRelated for bulk opening via tabbrowser.loadTabs, r=dao
https://hg.mozilla.org/mozilla-central/rev/d34178082ca8
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 60 → Firefox 61
Duplicate of this bug: 1454873
Bug 1454873 was closed as duplicate of this bug
and this bug is fixed but still the problem happens?
Flags: needinfo?(dao+bmo)
See my comment in the bug 1454873.  Also, please do not repeat the same post on multiple bugs.
Flags: needinfo?(dao+bmo)
You need to log in before you can comment on or make changes to this bug.