Closed Bug 1442754 Opened 2 years ago Closed 2 years ago

Loading about:addons new window focuses an existing about:addons tab in a different window

Categories

(Firefox :: Tabbed Browser, defect, major)

59 Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: harloczek, Unassigned)

Details

Steps
1. Launch Firefox DevEdition 59 beta 14.
2. Open the Add-ons Manager from menu [≡] → Add-ons.

Expected results:
1. The browser is successfully launched.
2. The "about:addons" page is successfully loaded in a new tab.

Results:
1. The browser is successfully launched.
2. The "about:addons" page is loaded in a new tab in a Default window not in Private Browsing window.
I'm having trouble understanding the steps here. At what point do you open a private window, and when do you open the add-ons page?
Component: Private Browsing → Tabbed Browser
Flags: needinfo?(harloczek)
1. Launch Firefox with default profile.
2. Open the Add-ons Manger.
3. Open the private window.
4. Open the Add-ons Manager in private window.

Then appears the window with default profile and with the "about:addons" page opened (what was done in step 2).
Flags: needinfo?(harloczek)
The same behaviour occurs with two non-private windows as well.
Summary: "about:addons" tab in Private Browsing window opens in Default window → Loading about:addons new window focuses an existing about:addons tab in a different window
This is intended behavior.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.