Closed Bug 1443147 Opened 2 years ago Closed 2 years ago

JS Shell builds broken on POSIX since bug 1441454

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: Alex_Gaynor, Assigned: jorendorff)

References

Details

Attachments

(1 file)

Errors look like:

Step #4: In file included from /src/mozilla-central/js/src/build_DBG.OBJ/js/src/shell/Unified_cpp_js_src_shell0.cpp:11:
Step #4: /src/mozilla-central/js/src/shell/js.cpp:8893:9: error: unknown type name 'PRLibSpec'
Step #4:         PRLibSpec libSpec;
Step #4:         ^
Step #4: /src/mozilla-central/js/src/shell/js.cpp:8894:24: error: use of undeclared identifier 'PR_LibSpec_Pathname'
Step #4:         libSpec.type = PR_LibSpec_Pathname;
Step #4:                        ^
Step #4: /src/mozilla-central/js/src/shell/js.cpp:8896:59: error: use of undeclared identifier 'PR_LD_NOW'
Step #4:         PRLibrary* dll = PR_LoadLibraryWithFlags(libSpec, PR_LD_NOW | PR_LD_GLOBAL);
Step #4:                                                           ^
Step #4: /src/mozilla-central/js/src/shell/js.cpp:8896:71: error: use of undeclared identifier 'PR_LD_GLOBAL'
Step #4:         PRLibrary* dll = PR_LoadLibraryWithFlags(libSpec, PR_LD_NOW | PR_LD_GLOBAL);
Step #4:                                                                       ^
Step #4: 4 errors generated.
Steve, if you can get to this today, great; if not -- well, it happens on my machine, so I will be taking a look soon. :)
Flags: needinfo?(sphink)
Flags: needinfo?(jorendorff)
Flags: needinfo?(sphink)
Flags: needinfo?(jorendorff)
Assignee: nobody → jorendorff
Status: NEW → ASSIGNED
Comment on attachment 8956515 [details] [diff] [review]
Fix PosixNSPR build after bug 1441454

Review of attachment 8956515 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, ok. I have a patch that moves in the direction I'd like to go, by creating a new library loading interface (and then implementing it on top of NSPR if it is being used, otherwise using POSIX APIs). It would have been nice and easy, except I wanted to make it return a Result<>, and that got into the details of NSPR error handling... anyway, it works, but it's much too large a fix for this small issue. Your patch is better.

I still hope to improve my patch to work cross-platform, add in the 2 additional APIs needed by ctypes, and remove direct NSPR usage from spidermonkey entirely. Then expand out the non-NSPR implementation coverage until we can remove NSPR from spidermonkey.

If that isn't the very definition of overkill for this bug, then I don't know what is.
Attachment #8956515 - Flags: review?(sphink) → review+
Priority: -- → P1
Blocks: 1407143
No longer blocks: 1407143
https://hg.mozilla.org/mozilla-central/rev/926f80f2c5cc
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1443581
You need to log in before you can comment on or make changes to this bug.