gUM capture doesn't display capture indicators in notification tray on Android

VERIFIED FIXED in Firefox 60

Status

()

defect
P1
normal
VERIFIED FIXED
Last year
Last year

People

(Reporter: pehrsons, Assigned: pehrsons)

Tracking

({regression})

unspecified
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60+ verified, firefox61 verified)

Details

Attachments

(1 attachment)

STR:
1 go to https://mozilla.github.io/webrtc-landing/gum_test.html
2 click Audio & Video
3 approve the permission request

Expected: An entry in the notification tray saying that Firefox is currently capturing the user's camera and microphone.

Actual: No entry in the notification tray.


This reproduces on Nightly 60, *not* on 58 or 59.

The working hypothesis so far is that bug 1299515 regressed this, as it changed some of the backend logic and signaling bits for this.
Ok, unsure about the component. Marking it General for triage.
Component: Audio/Video → General
[Tracking Requested - why for this release]: Privacy regression blocking new 60 camera-off-on-disabled feature (bug 1299515).
Summary: gUM capture doesn't display capture indicators in notification tray → gUM capture doesn't display capture indicators in notification tray on Android
Priority: -- → P1
One issue found, I hope and think that is all:

Regressed by [1], because on Android the message part is still used per [2]. Not that it's used for anything useful however, so it should be a quick fix.

[1] https://hg.mozilla.org/mozilla-central/rev/871480d5c37d3ff8e2d011ca4700f550148d490d
[2] https://searchfox.org/mozilla-central/rev/8fa0b32c84f924c6809c690117dbd59591f79607/mobile/android/modules/WebrtcUI.jsm#69
Status: NEW → ASSIGNED
Comment on attachment 8958899 [details]
Bug 1443157 - Disregard aData for event recording-device-events.

https://reviewboard.mozilla.org/r/227770/#review233814

Looks reasonable to me and works when testing on my phone :)
Attachment #8958899 - Flags: review?(jhofmann) → review+
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2b393dc7ff57
Disregard aData for event recording-device-events. r=johannh
https://hg.mozilla.org/mozilla-central/rev/2b393dc7ff57
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Would be great to have full verification that this is now fixed in Nightly.
Flags: qe-verify+
Comment on attachment 8958899 [details]
Bug 1443157 - Disregard aData for event recording-device-events.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1299515
[User impact if declined]: No notification on OS level or in browser chrome that a camera or microphone capture is occurring on any website on Fennec.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: Yes, see comment 0
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Dead simple, removing a check on a variable we no longer set.
[String changes made/needed]: None
Attachment #8958899 - Flags: approval-mozilla-beta?
I was able to reproduce the issue on build 60.0a1 from 30-01 with Nexus 6P(Android 8.1.0) and Honor 8(Android 7.0).
Verified as fixed: build 61.0a1 from 30-19.
Devices: Nexus 6P(Android 8.1.0) and Honor 8(Android 7.0).
Comment on attachment 8958899 [details]
Bug 1443157 - Disregard aData for event recording-device-events.

android crash fix, beta60+
Attachment #8958899 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed: 60.0b5 build 1.
Devices: Samsung Galaxy Tab S3 (Android 7.0), Nexus 5 (Android 6.0.1), Xiaomi Mi Pad 2 (Android 5.1 x86).
Screenshot: https://i.imgur.com/pxNWBoF.png.
Status: RESOLVED → VERIFIED
Based on previous comments, the bug was verified as fixed on Nightly 61 and Beta 60. Remove the qe-verify+ flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.