Closed Bug 1443533 Opened 2 years ago Closed 2 months ago

Crash in libGLES_mali.so@0x23f454

Categories

(Core :: Graphics: Layers, defect, P3, critical)

Unspecified
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox58 --- unaffected
firefox59 --- wontfix
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is
report bp-f022361d-7280-41cf-9c0f-c2a320180306.
=============================================================

Seen while looking at Fennec crash stats. This crash affects 59 and 60 and the first signature is #11 top crash on fennec beta: http://bit.ly/2Hb0jSE. Appears from crash stats that 5 separate Samsung devices running API 22 are affected by this crash:

samsung 	SM-J200F 	22 (REL) 	armeabi-v7a 	10 	29.4%
samsung 	SM-J200M 	22 (REL) 	armeabi-v7a 	10 	29.4%
samsung 	SM-G5500 	22 (REL) 	armeabi-v7a 	7 	20.6%
samsung 	SM-J200G 	22 (REL) 	armeabi-v7a 	6 	17.6%
samsung 	SM-J200BT 	22 (REL) 	armeabi-v7a 	1 	2.9%

URLs are all youtube:

*https://m.youtube.com/watch?v=EedPfUeBf2A 
*https://m.youtube.com/watch?v=kLpH1nSLJSs 

Top 10 frames of crashing thread:

0 libGLES_mali.so libGLES_mali.so@0x23f454 
1 libGLES_mali.so libGLES_mali.so@0x2d8f0e 
2 libGLES_mali.so libGLES_mali.so@0x2cf742 
3 libgui.so libgui.so@0x32683 
4 libGLES_mali.so libGLES_mali.so@0x2b9f0a 
5 libEGL.so libEGL.so@0x12b91 
6 libgui.so libgui.so@0x32b95 
7 libgui.so libgui.so@0x32d65 
8 libart.so libart.so@0x1f4e51 
9 system@framework@boot.art system@framework@boot.art@0x1d8b426 

=============================================================
Any ideas Jamie?
Flags: needinfo?(jnicol)
Whiteboard: [gfx-noted]
I highly doubt any of these old phones got a software update so it must be a change we made. Snorp and I made some SurfaceTexture changes towards the end of last year but I'm not sure if any of them could be responsible.

Is this worth getting a device to try to reproduce? Or perhaps we could use EGL images instead of surfacetextures for video on these GPUs.
Flags: needinfo?(jnicol) → needinfo?(snorp)
Potentially these drivers don't like bug 1395497?
Yeah. Fairly low volume, all things considered. Looks like this is mostly on j2lte, which is the Samsung Galaxy J2. Probably just need to get one of those and see what's going on, I'd guess.
Flags: needinfo?(snorp)
This is the #4 top crash in 60 Beta 15, but volume is not high. I would expect when 60 gets to release we will see more crashes on these two device sets (besides the Samsung Galaxy J2 the other signature shows Samsung SM-N7505 as the top crasher).
Does this just affect older Samsung devices?
(In reply to Derek from comment #6)
> Does this just affect older Samsung devices?

From what I can see in crash stats so far, yes.
Updating flags. SM-N7505, which is the Samsung Galaxy Note 3 is also affected. That phone dates back to 2014.

No crashes in recent builds. Resolving as WFM.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.