Closed Bug 1443640 Opened 2 years ago Closed 2 years ago

Intermittent toolkit/components/extensions/test/xpcshell/test_ext_i18n_css.js | xpcshell return code: 0

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kmag)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Looks like this is caused by changes in bug 1438974. It's 100% reproducible with patch from bug 1373708. See following try pushes, the second one is on the top of https://hg.mozilla.org/try/rev/dd55c414f2ad

PASS https://treeherder.mozilla.org/#/jobs?repo=try&revision=542e2f6c6c929e3f3ed4bd510483ecb2f4ac511d
FAIL https://treeherder.mozilla.org/#/jobs?repo=try&revision=689a382a76f1788177316ad5ebe6f2dbedd7a019
Flags: needinfo?(bobbyholley)
Blocks: 1373708
I reproduced this locally. The stylesheet isn't getting applied.

The test looks quite suspicious: https://searchfox.org/mozilla-central/rev/44fa24847e4e73ce8932de4c8cf47559302e4ba2/toolkit/components/extensions/test/xpcshell/test_ext_i18n_css.js#104

So my take on this is that the test is flakily bouncing through the event loop and assuming that the stylesheet will be applied. Transfering NI to kmag, since we'll likely need to fix the test here.
Flags: needinfo?(bobbyholley) → needinfo?(kmaglione+bmo)
(In reply to Bobby Holley (:bholley) from comment #2)
> So my take on this is that the test is flakily bouncing through the event
> loop and assuming that the stylesheet will be applied. Transfering NI to
> kmag, since we'll likely need to fix the test here.

Yeah, I was never happy with that workaround, but decided to allow it for the sake of allowing the async JAR patches to land.

I think the problem here is that this test was originally written when we had no async options for loading extension stylesheets, so the CSS was guaranteed to be applied by the time we got the STATE_STOP state change. When we switched to async loading, the test continued to pass, mostly by accident.
Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
Comment on attachment 8957736 [details]
Bug 1443640: Fix race when validating applied CSS.

https://reviewboard.mozilla.org/r/226692/#review232488
Attachment #8957736 - Flags: review?(mixedpuppy) → review+
https://hg.mozilla.org/mozilla-central/rev/cb4f862e9dd4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.