Popup menus on http://www.aa.com/ don't work

RESOLVED DUPLICATE of bug 102578

Status

RESOLVED DUPLICATE of bug 102578
17 years ago
13 years ago

People

(Reporter: jrh, Assigned: samir_bugzilla)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0+) Gecko/20020510
BuildID:    0000000000

Basically, on the left side of the page at http://www.aa.com/, there's a menu
with a number of items, "Reservations," "Travel Information," etc. Attempting to
use a submenu will result in nothing apparently happening. I checked out the
source, it seems somewhat reasonable to me, but perhaps there's something
finicky in there. 
Netscape 4 on Linux follows the links properly. Mozilla 1.0rc2 on Windows 98
also does it properly, which is why I'm not convinced this is purely an HTML
problem.
By the way, this is a build I did on FreeBSD from a night or two ago.
I tried this under a completely fresh setup, so as not to have been contaminated
by my own preferences files to no effect.


Reproducible: Always
Steps to Reproduce:
1. Open http://www.aa.com/
2. Put your mouse over the "Reservations" Menu on the left side.
3. Manuever the mouse over to the "Vacation Packages" submenu (Or any one, for
that matter.)


Actual Results:  I didn't see anything happen. Like I say, I only seem to be
seeing this on my Unix box, didn't notice it with a similar build on a Windows
machine.


Expected Results:  Should have followed the link as expected.


I'm willing to try and debug this if anyone has any ideas, but I'm not familiar
enough with Mozilla's inner-workings to know where the intereresting places to
look would be.

Comment 1

17 years ago
Win95 RC2

WFM, pops up submenu after 4 or 5 seconds, and clicking on items in the submenu
goes to the appropriate link.
worksforme as well, linux trunk build 2002-05-14-09.
(Reporter)

Comment 3

17 years ago
Not sure how I can possibly prove it in that case, but it simply isn't working
for me... built on 5-10-02. This might get frustrating.
does this problem still exist with mozilla 1.1beta and a new profile?

Comment 5

16 years ago
WFM 1.1a on both Sparc/Solaris and Mac/OS 9.

Reporter, notice that on the "book flight" page there are no submenus to pop up,
they are disabled on that page.  Maybe you were on that page and thought there
was a problem?
(Reporter)

Comment 6

16 years ago
Running with Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1b) Gecko/20020731,
I still see the problem. And indeed, I am on the front page and it still does
not work.
does a new profile help? also wait some time, thet page must be _compleatly_
loaded until they work.
(Reporter)

Comment 8

16 years ago
A new profile doesn't help. What I will say though is that it does not happen
every single time. (I know, what a pain.) However, I just noticed a few of the
times I tried it, I could get it to work and a few other times it did not. The
page was completely loaded each of the times I attempted and I'm not really
seeing any sort of pattern..

Comment 9

16 years ago
I've noticed that it can be slow, and you may need to move the mouse off of 
the menu and then back on and wait several seconds, depending on the speed of 
your computer.

Comment 10

16 years ago
I'm using build 20030315 on linux. I can reproduce this sporadically. I believe
this is a duplicate of bug 102578.

Bug 102578 is about mouse clicks causing onmouseout handlers to fire when they
shouldn't. Here, the popup menus are DIVs with onmouseout handlers; the
onmouseout handler calls setTimeout() to make the DIV disappear after 10ms. So
mozilla has 10ms to see the button release and follow the link before the menu
disappears.

I find that if I do a quick press & release of the mouse, the menu items work
well, but if I hold the mouse down a bit before releasing it they don't work.
This is what you'd expect with bug 102578 and this page's onmouseout handler.
Someone with a slower/faster computer might find it harder/easier to get the
menus to work.

*** This bug has been marked as a duplicate of 102578 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Menus on this page not working as expected. → Popup menus on http://www.aa.com/ don't work
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.