Particular flash ad sporadically sends CPU to 100%

VERIFIED DUPLICATE of bug 132759

Status

()

VERIFIED DUPLICATE of bug 132759
17 years ago
17 years ago

People

(Reporter: wrightae, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051006

A Flash ad for Ananova Online Ticket Sales at http://www.ananova.com/news/ can
cause the CPU usage to jump to 100%. This effectively hangs Mozilla, and lasts
for several seconds. Other apps are usually still usable in this time. Other
flash ads on Ananova seems to be OK. It may be only part of the ad sequence that
causes the hang, as the browser is usable for much of the time. The ad itself
occasionally freezes for a while. Task Manager's CPU usage graph shows a regular
pattern of plateaux of 100% usage falling to about 50% in between.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.ananova.com/news/
2. If online ticket sales ad is present, CPU should hit 100% automatically
whilst looping, or e.g. if right-clicking on ad a few times. 


Actual Results:  Page and ad displayed correctly. Right-clicked on ad at bottom
of page (one at top has the same effect) - first time no problem, second time
CPU went to 100% for >10 seconds and Mozilla stopped responding during this
time. Although the system recovered, the hangs continued on a regular basis even
when the browser window was underneath several other windows. 

Expected Results:  Displayed the page and ad without eating my CPU :)

OS : NT 4 SP6
IE 5.5 displays the ad correctly without the CPU issue.

Comment 1

17 years ago
going to http://www.ananova.com/assets/ticketsbanner.swf seems to send mozilla
into 100% cpu usage

seen on 20020511 on win2k
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
we have a lot of bugs for this issue...cpu going 100% ..hm. gotta look
(Reporter)

Comment 3

17 years ago
Also seen on Win98SE running build 20020417. IE 5.5 does show a similar
oscillating CPU usage as the animation loops, but never goes above about 70%;
Mozilla still hits 100% and doesn't like it. 
Viewing just http://www.ananova.com/assets/ticketsbanner.swf shows the
oscillation but it does not reach 100% on this system. Perhaps the difference is
that http://www.ananova.com/news/ shows two copies of the ad?

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 132759 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.