Closed Bug 144391 Opened 18 years ago Closed 17 years ago

Failure to redirect to another site

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 170021
Future

People

(Reporter: mbnospam, Assigned: darin.moz)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020509
BuildID:    2002050908

In IE, the url http://www.aon.co.uk/ redirects to http://www.aon.com/uk/en/
(that url also works in Moz if entered directly) In Moz, however, there is some
kind of endless loop with a blank screen and the redirection never happens.

Reproducible: Always
Steps to Reproduce:
1.http://www.aon.co.uk/ into address field
2.
3.

Actual Results:  screen blanks, status line shows repeated "sending request
to..." followed by "Document done"

Expected Results:  Redirection to http://www.aon.com/uk/en/
Might be Networking:HTTP.

I see it on Linux -> NEW, OS/Platform=ALL

What happens?
1.)
http://webtools.mozilla.org/web-sniffer/view.cgi?url=http%3A%2F%2Fwww.aon.co.uk%2F

There is <META HTTP-EQUIV="REFRESH" CONTENT="1 URL=http://www.aon.com/uk/en">.
That address does not work, when called directly.

2)
http://webtools.mozilla.org/web-sniffer/view.cgi?url=http%3A%2F%2Fwww.aon.com%2Fuk%2Fen
does not return anything visible.

3) lynx -head -dump http://www.aon.com/uk/en works.

Might be a special response to Mozilla?

pi
Assignee: Matti → darin
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: imajes-qa → tever
Hardware: PC → All
I think the problem is simply the missing ";" after the "1" in the refresh
value.... that's incorrect syntax.

ccing jag, who wrote that parsing code.
mass futuring of untargeted bugs
Target Milestone: --- → Future
This is working in Moz 1.3b.  Fixed by bug 170021.  Duping.

*** This bug has been marked as a duplicate of 170021 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Component: Networking: HTTP → Embedding: Docshell
QA Contact: tever → adamlock
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.