horizontal margins are ignored when table width is greater than 100%

RESOLVED WORKSFORME

Status

()

Core
Layout: Block and Inline
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Uwe Schröder, Unassigned)

Tracking

({css1, testcase})

Trunk
css1, testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME [CSS1-5.5.4], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
If width is set to a value > 100% on a table element, margin-left is forced to
zero. See URL for a test case.

Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.0rc1) Gecko/20020417

Comment 1

16 years ago
I see it on Linux -> OS/Platform=ALL

There is probably already a bug covering this -> Whiteboard->DUPEME

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All
Hardware: PC → All
Whiteboard: DUPEME

Comment 2

16 years ago
Confirmed (2002051308, WinNT)

The code for handling this (nsHTMLReflowState.cpp - I think) says: "Special
rules for tables. In general, tables will stick to the left edge when they are
too large otherwise they behave like blocks."

Anyone know why? I can't find anything relating to this. Unless specified
otherwise, I would always expect them to behave like blocks. 
OS: All → Windows 95
Hardware: All → PC

Updated

16 years ago
OS: Windows 95 → All
Hardware: PC → All
Status: NEW → ASSIGNED
Component: Style System → Layout
Keywords: css1
Target Milestone: --- → mozilla1.1beta

Comment 3

15 years ago
A valid testcase with negativ left margin and a width over 100% for the TABLE
element.
[Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.0rc3) Gecko/20020523]

Andreas

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3corg/TR/html4/strict.dtd">
<html>
<head>
<title>Negative margins</title>
<style type="text/css">
body{ 
margin-left: 6%;
}
table{
margin-left: -6.38%;
width: 106.38%;
background-color: yellow;
}
</style>
</head>
<body>
  <table>
   <tr> 
    <td>If you see the tablecell with the yellow background flush left with the
edge of the window, then it's not a bug.</td>
   </tr>
  </table>
</body>
</html>
->Layout
Assignee: dbaron → attinasi
Status: ASSIGNED → NEW
QA Contact: ian → petersen

Comment 5

15 years ago
Created attachment 85898 [details]
Andreas' testcase

Updated

15 years ago
Keywords: testcase

Updated

15 years ago
Priority: -- → P3
Whiteboard: DUPEME → DUPEME [CSS1-5.5.4]
.
Assignee: attinasi → table
Component: Layout → Layout: Tables
Priority: P3 → --
QA Contact: cpetersen0953 → madhur
Target Milestone: mozilla1.1beta → ---
I'd think this is more likely a block problem.
Assignee: table → block-and-inline
Component: Layout: Tables → Layout: Block & Inline
QA Contact: madhur → ian

Comment 8

9 years ago
this is wfm with current trunk
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.