Closed Bug 1443933 Opened 4 years ago Closed 4 years ago

Extended tweet mentions are not expanded

Categories

(Chat Core :: Twitter, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1445778

People

(Reporter: freaktechnik, Assigned: freaktechnik)

Details

Attachments

(1 file)

Since quite some time twitter has been hiding away the full tweet, if it exceeded a total of 140 characters. This is correctly expanded for tweets getting received via timeline streaming, but those getting loaded via mentions history (don't know if there's a difference) do not get properly expanded.
This seems to apply to all historic tweets, not just mentions. They probably have a different object layout than the streamed tweets.
Feel free to redirect. Essentially just tells Twitter to send us the full tweets and then handles getting the full tweets (that no longer have a text property).
Assignee: nobody → martin
Status: NEW → ASSIGNED
Attachment #8957010 - Flags: review?(clokep)
Comment on attachment 8957010 [details] [diff] [review]
bug1443933-v1.patch

Review of attachment 8957010 [details] [diff] [review]:
-----------------------------------------------------------------

I think this looks sane overall. The amount of duplicate in parsing of tweets seems excessive, but that's not your fault.

I have one question in here though.

::: chat/protocols/twitter/twitter.js
@@ +195,5 @@
>        else {
> +        if ("full_text" in retweet)
> +          retweetText = retweet.full_text;
> +        else
> +          retweetText = retweet.text;

On line 191 we just always use full_text, does the "extended_tweet" object not get sent anymore or something?
(In reply to Patrick Cloke [:clokep] from comment #3)
> Comment on attachment 8957010 [details] [diff] [review]
> bug1443933-v1.patch
> 
> Review of attachment 8957010 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I think this looks sane overall. The amount of duplicate in parsing of
> tweets seems excessive, but that's not your fault.
> 
> I have one question in here though.
> 
> ::: chat/protocols/twitter/twitter.js
> @@ +195,5 @@
> >        else {
> > +        if ("full_text" in retweet)
> > +          retweetText = retweet.full_text;
> > +        else
> > +          retweetText = retweet.text;
> 
> On line 191 we just always use full_text, does the "extended_tweet" object
> not get sent anymore or something?

That's part of the messy Twitter endpoints. In the streaming APIs we get extended_tweet if necessary, in the REST APIs we only get full_text. So all this patch adds is to handle the full_text field from the REST APIs, without removing any of the handling for the streaming APIs.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1445778
Attachment #8957010 - Flags: review?(clokep)
You need to log in before you can comment on or make changes to this bug.