Closed Bug 1443957 Opened 2 years ago Closed 2 years ago

Yahoo search gone from search engines list

Categories

(Firefox :: Search, defect)

58 Branch
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: godbecky, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180206200532

Steps to reproduce:

search from address bar
I have it set to use yahoo search only when i search in firefox. Today i went to search from the address bar like I always do, and it went to amazon. So I tried again and it went to amazon. I checked my options and under one click search engines Yahoo is no longer listed. I posted a question on support mozilla and someone else has the same problem. I tried everything that people suggested and had to use a walk around to get yahoo back under search engines. I have 2 other computers and 2 phones all with the same problem. So I guess I have to use the same walk around to get yahoo back


Actual results:

went to amazon instead of yahoo search


Expected results:

should have searched using yahoo search
Component: Untriaged → Search
Related threads:

SuMo: 

https://support.mozilla.org/questions/1208139 (Win7)
https://support.mozilla.org/questions/1208277 (Win10)

Reddit: 

https://www.reddit.com/r/firefox/comments/82udws/right_clicking_highlighted_text_and_clicking/

Notes:

* Yahoo does not appear in the One-click box, and the "Restore Default Search Engines" button is grayed

* Removing search.json.mozlz4 (and search.json) does not restore Yahoo

* No Autoconfig files detected

* No Shield studies listed

* Affected users still have yahoo.xml in omni.ja as confirmed by checking these URLs: resource://search-plugins/yahoo.xml and      chrome://browser/locale/searchplugins/

* Yahoo search can be re-enabled from other sources (e.g., https://addons.mozilla.org/firefox/addon/yahoo-search-addon/ or http://mycroftproject.com/yahoo-search-plugins.html ) after which the search plugin stays installed, it is not removed (so far!)

Very mysterious.
On SuMo, cor-el has identified this:

Automatic search engine update returns an incomplete result on:

https://search.services.mozilla.com/1/firefox/58.0.2/release/en-US/US/default/default

{"cohort": "nov17-2", "interval": 86400, "settings": {"searchDefault": "Google", "visibleDefaultEngines": ["amazondotcom", "bing", "ebay", "google-2018", "twitter", "wikipedia", "ddg"]}}

Is this intentional?

https://support.mozilla.org/questions/1208139?page=3#answer-1085729
Ok from one of the posts about this we found the solution 

JSCHER and COR-EL thank you again if you see this 


Does that mean that if you turn off the "geo-specific" feature, you will get the full list again, the next time you regenerate search.json.mozlz4?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste geos and pause while the list is filtered

(3) Double-click the browser.search.geoSpecificDefaults preference to switch the value from true to false

Then the steps to have Firefox generate a new search.json.mozlz4 file are here: https://support.mozilla.org/questions/1208139?page=1#answer-1085333

Still shouldnt be happening and as end users we really shouldnt have to go into the config files and delete or change things. 

But this does work to get Yahoo back and you can set it as default again
please reinstall the yahoo engine from their official webpage, it's no more one of the default engines.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Marco, 
I need clarification. What do you mean? Do I have to reinstall something? I thought we had a work around that was ok?

Thanks
Becky
if the workaround works for you that's good.
Otherwise, you can just add back the yahoo opensearch from the yahoo homepage itself.
Customize your Firefox (Right click on the toolbar and Customize), drag the search bar on the toolbar, if you don't have it, and click Done.
Open the yahoo homepage, click on the magnifier lens with the + sign (in the search bar) and choose "Add Yahoo search".
Finally, to remove the search bar just right click on the search magnifier and choose "Remove from toolbar" to remove the search bar.
We are working in bug 1221539 to add the same feature to the Address Bar, but it's not ready yet.
Yeah we talked about adding it back that way and it works alright but I wasnt able to set Yahoo as my default search that way. The work around we got I am now able to set Yahoo as my default search.
After adding any engine, you can right click on the engine in the URL bar and select "set as default engine" to make any engine your default.

I do not recommend the geoSpecificDefaults change. It will not continue to work that way.
I went an unchecked automatically update search engines so wont that keep it from changing on me?
> I went an unchecked automatically update search engines so wont that keep it from changing on me?

That controls whether or not a search engine can update itself.
Hi Becky, the workaround of blocking the current U.S. English search engine update (plus, if necessary, having Firefox regenerate the search.json.mozlz4 file) allows Firefox 58.0.2 to continue to show all of the the currently built-in search plugins. 

However, if the yahoo.xml file is removed completely in Firefox 59, the workaround would stop working at that point and you would need to install a Yahoo search plugin from another source.

Other notes:

* I submitted a Yahoo.com Search plugin to the Add-ons site for greater convenience, but it still needs to be reviewed. No idea how long that will take.

* Meanwhile, I created a page with a button to install Yahoo's own plugin (and variations thereon) for users do not want to customize their toolbar: https://www.userchrome.org/yahooxml.html
Hey Jscher, Have I mentioned how Awesome you are!

Thanks so much
(In reply to Marco Bonardo [::mak] from comment #4)
> please reinstall the yahoo engine from their official webpage, it's no more
> one of the default engines.

Related discussion:
https://support.mozilla.org/en-US/forums/contributors/712925#post-73601 Yahoo no longer a built-in search engine
(quote) "Here's the checkin: https://hg.mozilla.org/releases/mozilla-release/rev/a46d7b315f70 That references bug 1442738, in which access is restricted."
Thank you Alice. I still say its nuts to make users do this. But at least its easier to get it back. But my question is , will you have to do this EVERY time there is an update?
(In reply to becky from comment #15)
> Thank you Alice. I still say its nuts to make users do this. But at least
> its easier to get it back. But my question is , will you have to do this
> EVERY time there is an update?

I don't know if a future search engine update is in the works that will again remove Yahoo Search, after you use the steps in comment 6 (or in https://support.mozilla.org/en-US/kb/forum-response-add-yahoo-search-to-firefox which is based on that comment).  Hopefully someone else can answer but https://support.mozilla.org/en-US/forums/contributors/712925 might be a better place for this discussion.
(In reply to becky from comment #15)
> But my question is , will you have to do this
> EVERY time there is an update?

No, Firefox tries to respect your choices whenever possible and unless there's a bug, that we can't predict unfortunately. Once you install an opensearch engine by your will, Firefox should never touch it (I repeat, modulo bugs).
Ok thank you both
(In reply to Marco Bonardo [::mak] from comment #4)
> please reinstall the yahoo engine from their official webpage, it's no more
> one of the default engines.

Do you know the reason why this happened in the first place? Is something broken in the plugin? Will yahoo make it back to the default engines? I appreciate the workarounds provided by jscher very much, but I was expecting the resolution would be to restore yahoo to default engines instead of expecting our users somehow find this page and use the workaround.
Flags: needinfo?(adw)
Sunlip 
We really have no idea. Did figure out it was just the US version of firefox though. But no idea why some ideas but who really knows. And as long as you take and uncheck the box automatically update search engines, it doesnt mess with yahoo being your default search. Since there was an update a few days ago and then yesterday again, my yahoo is still there.
I don't have anything to add to what Marco said, which is correct.
Flags: needinfo?(adw)
You need to log in before you can comment on or make changes to this bug.