Remove remaining add-on interpositions

RESOLVED FIXED in Firefox 60

Status

()

enhancement
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: kmag, Assigned: kmag)

Tracking

57 Branch
Firefox 60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

a year ago
+++ This bug was initially created as a clone of Bug #1443964 +++
Assignee

Updated

a year ago
No longer blocks: 1439713
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 4

a year ago
mozreview-review
Comment on attachment 8957041 [details]
Bug 1443983: Part 3 - Remove platform support for interpositions.

https://reviewboard.mozilla.org/r/225998/#review232026

Nice.
Attachment #8957041 - Flags: review?(continuation) → review+

Comment 5

a year ago
mozreview-review
Comment on attachment 8957039 [details]
Bug 1443983: Part 1 - Remove shim usage in browser_google_behavior.js.

https://reviewboard.mozilla.org/r/225994/#review232030

Excellent, thanks.
Attachment #8957039 - Flags: review?(mconley) → review+

Comment 6

a year ago
mozreview-review
Comment on attachment 8957040 [details]
Bug 1443983: Part 2 - Remove remaining interpositions.

https://reviewboard.mozilla.org/r/225996/#review232034

I am not at all sorry to see this stuff go. Thanks so much, kmag.

::: toolkit/content/browser-child.js
(Diff revision 1)
> -    if (RemoteAddonsChild.useSyncWebProgress) {
> -      sendRpcMessage(name, data, objects);
> -    } else {

Oh thank goodness

::: toolkit/mozapps/extensions/AddonManagerStartup.cpp:514
(Diff revision 1)
>  /*****************************************************************************
>   * XPC interfacing
>   *****************************************************************************/
>  
>  static void
> -EnableShimsAndCPOWs(const nsAString& addonId, bool enableShims)
> +EnableShimsAndCPOWs(const nsAString& addonId)

This should probably just be EnableCPOWs or something similar now.

::: toolkit/mozapps/extensions/AddonManagerStartup.cpp
(Diff revision 1)
>  
>    if (!Preferences::GetBool("extensions.defaultProviders.enabled", true)) {
>      return NS_OK;
>    }
>  
> -  bool enableInterpositions = Preferences::GetBool("extensions.interposition.enabled", false);

This pref needs to be removed from firefox.js.
Attachment #8957040 - Flags: review?(mconley) → review+
Assignee

Updated

a year ago
Assignee: nobody → kmaglione+bmo
Assignee

Comment 7

a year ago
mozreview-review-reply
Comment on attachment 8957040 [details]
Bug 1443983: Part 2 - Remove remaining interpositions.

https://reviewboard.mozilla.org/r/225996/#review232034

> This pref needs to be removed from firefox.js.

Oh, good catch. I meant to remove that.
Assignee

Comment 9

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/bce9970180dc86666599d1af464beab098976fa7
Bug 1443983: Follow-up: Force initial about:blank browser to non-remote. r=me
Assignee

Comment 10

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a091ec4e060846c84d650395791b095ef4c73e4
Bug 1443983: Follow-up: Add preferredRemoteType to addTab call to fix another unexpected intermittent. r=bustage

Comment 12

a year ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c1203e6ba317
Remove add-on interpositions from SeaMonkey Installer. rs=bustage-fix

Comment 13

a year ago
Backout by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/08c61155ede7
Backed out changeset: c1203e6ba317 for landing with the wrong bug number.
Duplicate of this bug: 1395815
You need to log in before you can comment on or make changes to this bug.