If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

vertical misalignment of hyperlink images

VERIFIED DUPLICATE of bug 5821

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 5821
18 years ago
18 years ago

People

(Reporter: metrol, Assigned: don)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
On both M8 and M9 I've been seeing some weird stuff with table layout on some
of the pages that I've designed.  On the listed URL there is a nav bar at the
top of the page that should appear like a single bar.  It shows up correctly in
other 4.0 browsers, but M9 is doing something mighty weird there.
  I have some pages in development now that also have this problem when mixing
foreground and background images in the table.  To make matters worse, I've got
other pages doing this that show up perfectly in M9.
  Also, the JavaScript I used on this page to create the rollover effect on this
toolbar sometimes gets stuck with the second image.  I assume this is due to M9
not properly seeing the OnMouseOut event.
  While working on a re-write of this site I used a Dreamweaver behavior to do
the mouseover effect.  I hate the code it produces, but I was looking for a
quick way to do it for initial layout and testing purposes.  Dreamweaver's code
does not seem to have this sticking problem.  Unfortunately I don't have this
version of the site publicly available yet, but this should be relatively
straight forward to replicate.
  I didn't see either of these issues brought up as of yet on Bugzilla, thus
this note.  My apologies if it this has already been posted.

Michael Collette
metrol@netscape.net

Updated

18 years ago
Component: Browser-General → HTMLTables
Whiteboard: [TESTCASE]

Comment 1

18 years ago
This bug occurs whenever several adjacent images are contained within seperate
cells in a table. If these are just plain images they will line up correctly,
but if however one image is being used as a hyperlink (is contained within
<A ...> and </A> elements) it is moved out of alignment vertically.

Comment 2

18 years ago
Created attachment 1797 [details]
test case showing vertical misalignment of images within table

Updated

18 years ago
Summary: Tables with background graphics → vertical misalignment of hyperlink images

Comment 3

18 years ago
Created attachment 1798 [details]
CORRECT test case show veritcal misalignment o images in a table

Comment 4

18 years ago
Please ignore the previous two test cases as they are failed attempts at
including an example image with the testcase. I have now discovered that it is
possible to provide a test case demonstrating this bug without any images. So I
have now created a third test case to replace the other two.

Comment 5

18 years ago
Created attachment 1800 [details]
!!! WORKING TESTCASE !!! demonstrating misalignment of images
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Duplicate of already "fixed" non-bug.

*** This bug has been marked as a duplicate of 5821 ***
(Reporter)

Comment 7

18 years ago
Would there be any value in my posting a seperate bug report on the JavaScript
problem this same page has got?  For some reason the script on this page doesn't
seem to properly deal with onMouseOut.

Comment 8

18 years ago
Resetting QA contact from leger.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Verified dup of #5821
You need to log in before you can comment on or make changes to this bug.