Rename a couple of atom-related things

RESOLVED FIXED in Firefox 60

Status

()

enhancement
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: njn, Assigned: njn)

Tracking

Trunk
mozilla60
Points:
---

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

a year ago
This is a precursor to bug 1411469.
(Assignee)

Updated

a year ago
Blocks: 1411469
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 3

a year ago
mozreview-review
Comment on attachment 8957075 [details]
Bug 1444031 - Rename Is{Static,Dynamic,HTML5}Atom.

https://reviewboard.mozilla.org/r/226028/#review232146

Sure.
Attachment #8957075 - Flags: review?(nfroyd) → review+

Comment 4

a year ago
mozreview-review
Comment on attachment 8957076 [details]
Bug 1444031 - Rename nsStaticAtom::mAtom as mAtomp.

https://reviewboard.mozilla.org/r/226030/#review232148

Bikeshed: Just call this `mAtomPtr`?  Or `mAtomLoc`?  `mAtomp` seems a little too terse.
Attachment #8957076 - Flags: review?(nfroyd) → review+
(Assignee)

Comment 5

a year ago
Oddly enough, I find the 'p' suffix clearer for a pointer to a pointer. I think there is precedent elsewhere. (E.g. the 'atomp' local in RegisterStaticAtoms().) In contrast, a "Ptr" suffix makes me think it's a single-level pointer, like RefPtr or AutoPtr or UniquePtr. So I'll stick with mAtomp.

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d660ed0a7b46
https://hg.mozilla.org/mozilla-central/rev/02a9e772183c
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee: nobody → n.nethercote
You need to log in before you can comment on or make changes to this bug.