Rules inspector gives misleading warning for unrecognized properties

RESOLVED DUPLICATE of bug 1411664

Status

enhancement
RESOLVED DUPLICATE of bug 1411664
a year ago
11 months ago

People

(Reporter: jwatt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I've just been trying to debug a testcase involving the 'user-select' property, and the Rules Inspector told me that for |user-select: none;| the rule has an "Invalid property value". That misleading warning sent me off trying to figure out if there's a bug in our implementation and the values it accepts, only to figure out that we don't actually support the unprefixed property name.

It would be much better if the Rules Inspector would have distinct "Invalid property" and "Invalid property value" error messages.
Thanks Jonathan. I think this is a duplicate of bug 1411664. Closing now. Feel free to re-open if I misunderstood.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1411664

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.