Closed Bug 1444487 Opened 2 years ago Closed 2 years ago

Create new preference for whether langpacks must be signed

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox60 + verified
firefox61 --- verified

People

(Reporter: aswan, Assigned: aswan)

References

Details

Attachments

(2 files)

For now this preference can be manually toggled and will default to false.  After other dependencies of the parent bug are addressed and QA has had a chance to test, we can lock this down further.
Attachment #8957643 - Flags: review?(kmaglione+bmo)
Comment on attachment 8957643 [details]
Bug 1444487 Add preference for langpack signing

https://reviewboard.mozilla.org/r/226544/#review232428

Should really have a test for this...
Attachment #8957643 - Flags: review?(kmaglione+bmo) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ed7f3c8ad84
Add preference for langpack signing r=kmag
https://hg.mozilla.org/mozilla-central/rev/9ed7f3c8ad84
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Comment on attachment 8957643 [details]
Bug 1444487 Add preference for langpack signing

Approval Request Comment
[Feature/Bug causing the regression]:
n/a, not a regression

[User impact if declined]:
no direct user impact, this is part of bug 1197876, it will allow QA to test signed language packs on beta.

[Is this code covered by automated tests?]:
yes

[Has the fix been verified in Nightly?]:
yes

[Needs manual test from QE? If yes, steps to reproduce]: 
this patch doesn't need additional manual testing but as mentioned above, it will be used to manually test browser behavior when language pack signing is required.

[List of other uplifts needed for the feature/fix]:
none

[Is the change risky?]:
not particularly

[Why is the change risky/not risky?]:
the change is small and between existing automated tests plus the new test added in the patch, the affected areas are well tested.

[String changes made/needed]:
none
Attachment #8957643 - Flags: approval-mozilla-beta?
set to 60 fixed - since we are targeting 60 Beta.  This is to ride with ESR (which is why we want 60)
Assuming you wanted affected rather than fixed since this isn't in 60 yet.
Comment on attachment 8957643 [details]
Bug 1444487 Add preference for langpack signing

langpack signing support, for 60.0b4
Attachment #8957643 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Setting qe-verify- on this bug since it has automated coverage and it does not need manual testing (per Comment 6).
Flags: qe-verify-
Attached image Bug1444487.gif
This issue is verified as fixed on Firefox 61.0a1(20180316100132) and Firefox 60.0b4(20180315232954) under Windows 7 64-bit and Mac OS X 10.13.2.

The preference “extensions.langpacks.signatures.required” is set to false by default.

With the preference set to true or false only the signed langpacks can be installed in Fx61 or Fx60.

Unsigned langpacks can be installed only if the preference is set to false.

Please see the attached video.
Status: RESOLVED → VERIFIED
Flags: qe-verify-
Depends on: 1446948
You need to log in before you can comment on or make changes to this bug.