Closed Bug 1444502 Opened 2 years ago Closed 2 years ago

Remove support for installing unpacked extensions

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: kmag, Assigned: kmag)

References

Details

Attachments

(1 file)

We only support unpacked extensions that are installed for development purposes at this point. The add-on manager code for installing them, and the extra set of tests we run for unpacked extensions, is useless overhead at this point.
Apparently dictionaries still only work unpacked, so I'm going to restrict this to removing support for the em:unpack attribute, and making dictionaries automatically unpacked.
Comment on attachment 8957678 [details]
Bug 1444502: Remove support for installing unpacked extensions.

https://reviewboard.mozilla.org/r/226602/#review232602

Thanks.  xpcshell.ini is kind of disaster right now but cleaning that up can wait for another day.
Attachment #8957678 - Flags: review?(aswan) → review+
https://hg.mozilla.org/mozilla-central/rev/b8b11082ff88
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 1439668
Is manual testing required on this bug? If yes, please provide some STR and the proper extension(if required) or set the “qe-verify -“ flag.

Thanks!
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(kmaglione+bmo) → qe-verify-
I would like to point that we need to unpack if you have a binary component in the add-on (https://developer.mozilla.org/en-US/docs/Archive/Add-ons/Install_Manifests > see unpack).
In my case, I use ctypes : https://developer.mozilla.org/en-US/docs/Mozilla/js-ctypes

Since there is no other solution yet (WebExtension does not seem to be ready), unpack attribute is needed
Binary components and ctypes have not been supported in extensions for years
There were still working in Thunderbird 59, is there a workaround?
Working and supported are not the same thing. We banned ctypes in extensions as a policy matter when we removed support for binary components. Thunderbird has its own policies, but as far as mozilla-central goes, they're unsupported. If you need a workaround, I can suggest webassembly or Subprocess.jsm. Otherwise, you'll have to ask the Thunderbird team.
You need to log in before you can comment on or make changes to this bug.