Closed Bug 1444581 Opened 2 years ago Closed 2 years ago

[UI Events] Set key value of keydown/keyup event to "AltGraph" if active keyboard layout has actually AltGr and pressed AltRight key on Windows

Categories

(Core :: Widget: Win32, enhancement)

All
Windows
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 900750
Tracking Status
firefox60 --- affected

People

(Reporter: masayuki, Assigned: masayuki)

Details

In https://github.com/w3c/uievents/issues/147, Google suggested better AltGr event dispatching on Windows.

On Windows, AltGr is represented as both Ctrl and Alt keys are pressed. Therefore, currently, we never dispatch AltGr key events on Windows but this is not good behavior for web developers.

First, we need to change KeyboardLayout a little bit to check if active keyboard layout has AltGr key actually.

Next, if active keyboard layout has AltGr and AltRight key is pressed, we should set key value to AltGr in this case (and clear Alt and Control modifier state).

Google Chrome has implemented this:
https://chromium-review.googlesource.com/c/chromium/src/+/558584

Although I'm not sure when we should enable this in default settings.
Blocks: 1389739
Oops, I forgot there is a bug for this.
No longer blocks: 1389739
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900750
You need to log in before you can comment on or make changes to this bug.