Closed Bug 1444768 Opened 3 years ago Closed 3 years ago

Intermittently cannot search from the address bar until after restart

Categories

(Firefox for Android Graveyard :: General, defect)

58 Branch
defect
Not set
normal

Tracking

(fennec?)

RESOLVED INACTIVE
Tracking Status
fennec ? ---

People

(Reporter: peterjoel, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (Android 7.0; Tablet; rv:58.0) Gecko/58.0 Firefox/58.0
Build ID: 20180206200532

Steps to reproduce:

This happens periodically, but it will happen most days eventually. It occurs when I type a URL or search term in the address bar.

Firefox 58.0.2
Samsung Galaxy Tab S2 (SM-T813)
Android 7.0




Actual results:

The progress bar under the address stalls at ~10% and never gets further. Quitting Firefox and restarting always fixes it.


Expected results:

The web page should load without needing a browser restart.
tracking-fennec: --- → ?
This might be narrower than I first thought and only affect searching from the address bar. At least that is what I'm now seeing: I'm able to navigate to A URL but I can't search.

Steps:

After Firefox has got into this state, observe the bug by:

1. Type a query in the address bar
2. Touch enter on soft keyboard

Results:

The soft keyboard closed. The search term remains in the address bar but no navigation happens. Pressing the refresh button will just reload the current page and put the  current page's address in the address bar.

This seems to be a permanent state that cannot be exited without a restart.
Summary: Page intermittently doesn't load until restart → Intermittently cannot search from the address bar until after restart
Hello Peterjoel,

I couldn't reproduce this issue following the steps from the description and Comment 1 on the latest Nightly with a Samsung Galaxy S8+ Android 8.0.0.
I tried many web sites but every time the search worked as expected.

Can you please give some more information about what Device(with android) and sites you used when reproducing this issue?
Also, can you please check what is your search engine?(Tap on the 3 dots menu --> Search --> Installed Search Engines) The first one is the one that you are using.

Regards,
Andrei
Flags: needinfo?(peterjoel)
Closing per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Contact :susheel if you think this bug should be re-opened
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INACTIVE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.