Enabling usebuggroups and usebuggroupsentry causes errors

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
--
major
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Steve Wardell, Assigned: justdave)

Tracking

Details

(Reporter)

Description

16 years ago
So I installed a fresh copy of 2.16RC1 software. I copied over the MySQL 
DB files form an installation I have have 2.14.1. I run the 
checksetup.pl and set the password for my DB account. Everything seems 
ok. Then I enabled usebuggroups and usebuggroupsentry. Now, My Bugs and 
most bug areas don't work. The output is the text below. 

Please stand by ...
Content-type: text/html
Software error:

SELECT DISTINCT bugs.bug_id, bugs.groupset, bugs.bug_severity, 
bugs.priority, bugs.rep_platform, map_assigned_to.login_name, 
bugs.bug_status, bugs.resolution, bugs.short_desc FROM bugs, profiles 
map_assigned_to, profiles map_reporter LEFT JOIN profiles map_qa_contact 
ON bugs.qa_contact = map_qa_contact.userid LEFT JOIN cc cc_ ON 
bugs.bug_id = cc_.bug_id LEFT JOIN profiles map_cc_ ON cc_.who = 
map_cc_.userid LEFT JOIN cc selectVisible_cc ON
                      bugs.bug_id = selectVisible_cc.bug_id AND
                      selectVisible_cc.who = 2 WHERE ((bugs.groupset & 
127) = bugs.groupset OR (bugs.reporter_accessible = 1 AND bugs.reporter 
= 2)
                    OR (bugs.cclist_accessible = 1 AND 
selectVisible_cc.who = 2 AND not isnull(selectVisible_cc.who))) AND 
bugs.assigned_to = map_assigned_to.userid AND bugs.reporter = 
map_reporter.userid AND (bugs.bug_status = 'UNCONFIRMED' OR 
bugs.bug_status = 'NEW' OR bugs.bug_status = 'ASSIGNED' OR 
bugs.bug_status = 'REOPENED') AND (map_cc_.login_name = 
'swardell@team.bantu.com') ORDER BY bugs.bug_id : Got error 127 from 
table handler at globals.pl line 276.

For help, please send mail to the webmaster (root@localhost), giving 
this error message and the time and date of the error.

Comment 1

16 years ago
> Got error 127 from table handler

What does the mysql manual say about error 127?

Are you sure you are running exactly the same OS and the same MySQL version on
both the 2.14.1 and 2.16rc1 machines? Have you shut down the 2.14.1 MySQL daemon
before copying the files? Or is this even on the same machine? 
Can you try using mysqldump to produce a plaintext version of the original
database, and then importing it into the new database using something like
mysql -ubugs bugs <origdb.sql ? Does the error still occur?
Can you be a bit more precise what you mean by "most bug areas" not working?
$ perror 127
Error code 127:  Unknown error 127
127 = Record-file is crashed

Sounds like you have db corruption, and need to repair the table, and/or restore
from backups.
(Reporter)

Comment 3

16 years ago
That seems to have fixed it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.