Closed Bug 1445278 Opened 2 years ago Closed 2 years ago

Search is broken on Firefox 52.7.0 - Italian build

Categories

(Firefox :: Search, defect, critical)

52 Branch
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
relnote-firefox --- 59+
firefox-esr52 59+ verified
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected

People

(Reporter: informatica, Assigned: RyanVM)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180310025718

Steps to reproduce:

put a address without http:// before not enable search and enter or the arrow on navigation bar not run


Actual results:

update firefox 52.6 esr to 52.6 esr or install latest ESR version (52.7.0)


Expected results:

after put a world without http on address bar and type return start the search
after update firefox 32/64 bit at version 52.7.0 on win 7 64bit i lost function search on navigation bar and in option tab search.  if i install firefox 59 the problem didisappared
Severity: normal → major
Component: Untriaged → Search
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Confirm the bug, on Windows 10 x64, firefox 32bit 52.7.0 ITALIAN language
(In reply to informatica from comment #0)
> Steps to reproduce:
> put a address without http:// before not enable search and enter or the
> arrow on navigation bar not run

Can you clarify what the problem is and how to reproduce it? 

You type a word in the address bar, press enter and nothing happens? Or that happens with an address?

Feel free to switch to Italian if it helps.
One more question: if you go into preferences, is there a default Search Engine selected? What are the search engines displayed?
Flags: needinfo?(informatica)
Flags: needinfo?(alessio1971)
Downloaded 52.7.0 Italian from here
https://www.mozilla.org/it/firefox/organizations/all/?q=italian

Created a new profile:
a) I type a word in the address bar, press enter, and nothing happens

Unable to initialize search service.  PlacesSearchAutocompleteProvider.jsm:45
uncaught exception: 2147500037  browser.js:2133:18
uncaught exception: 2147500037  urlbarBindings.xml:261:23

b) Try to open the Search panel

uncaught exception: 2147500037  search.js:329:19
Error initializing preference category paneSearch: [Exception... "Failure'Failure' when calling method: [nsIBrowserSearchService::getVisibleEngines]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/preferences/in-content/search.js :: EngineStore :: line 329"  data: no]  preferences.js:180
NS_ERROR_FAILURE: Failure'Failure' when calling method: [nsIBrowserSearchService::getVisibleEngines]  search.js:329
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(informatica)
Flags: needinfo?(alessio1971)
Summary: after updata firefox 32/64 bit at version 52.7.0 on win 7 64bit i lost function search on navigation bar and in option tab search. if i install firefox 59 the problem didisappared. → Search is broken on Firefox 52.7.0
Everything appears to work OK with en_US builds. Mike, can you please take a look?
Flags: needinfo?(mozilla)
Summary: Search is broken on Firefox 52.7.0 → Search is broken on Firefox 52.7.0 (possibly locale-specific)
Tried es-ES and it works. Got reports that French works fine too. 

I tried starting Italian offline, and creating a new profile, but got the same error. 

list.json inside the build seems correct

{"default": {"visibleDefaultEngines:": ["google", "bing", "amazon-it", "ddg", "hoepli", "wikipedia-it"]}}

But the searchplugins folder in browser/omni.ja is completely empty.
Summary: Search is broken on Firefox 52.7.0 (possibly locale-specific) → Search is broken on Firefox 52.7.0 (Italian version)
Summary: Search is broken on Firefox 52.7.0 (Italian version) → Search is broken on Firefox 52.7.0 (only for some locales)
Bug has been reproduced on Linux and macOS too.
OS: Windows 7 → All
Hardware: x86_64 → All
We tracked it down to an extraneous change introduced by the patch from bug 1442738:
https://hg.mozilla.org/releases/mozilla-esr52/rev/a1eb1ccaf4f1#l5.399

I'm landing a patch to revert that now.
Note this did show up as a build error, but wasn't fatal:

17:27:12     INFO - Traceback (most recent call last):
17:27:12     INFO -   File "c:\mozilla-build\python27\Lib\runpy.py", line 162, in _run_module_as_main
17:27:12     INFO -     "__main__", fname, loader, pkg_name)
17:27:12     INFO -   File "c:\mozilla-build\python27\Lib\runpy.py", line 72, in _run_code
17:27:12     INFO -     exec code in run_globals
17:27:12     INFO -   File "c:\builds\moz2_slave\rel-m-esr52_fx_w64_l10n_rpk-00\build\mozilla-esr52\python\mozbuild\mozbuild\action\output_searchplugins_list.py", line 17, in <module>
17:27:12     INFO -     engines = list(set(engines)|set(searchinfo["locales"][locale][region]["visibleDefaultEngines"]))
17:27:12     INFO - KeyError: 'visibleDefaultEngines'

So we'll want a bug for that as well.

My sincerest apologies for the screw up.
Flags: needinfo?(mozilla)
Summary: Search is broken on Firefox 52.7.0 (only for some locales) → Search is broken on Firefox 52.7.0 - Italian build
(In reply to Mike Kaply [:mkaply] from comment #10)
> Note this did show up as a build error, but wasn't fatal:
> 
> 17:27:12     INFO - Traceback (most recent call last):
> 17:27:12     INFO -   File "c:\mozilla-build\python27\Lib\runpy.py", line
> 162, in _run_module_as_main
> 17:27:12     INFO -     "__main__", fname, loader, pkg_name)
> 17:27:12     INFO -   File "c:\mozilla-build\python27\Lib\runpy.py", line
> 72, in _run_code
> 17:27:12     INFO -     exec code in run_globals
> 17:27:12     INFO -   File
> "c:\builds\moz2_slave\rel-m-esr52_fx_w64_l10n_rpk-00\build\mozilla-
> esr52\python\mozbuild\mozbuild\action\output_searchplugins_list.py", line
> 17, in <module>
> 17:27:12     INFO -     engines =
> list(set(engines)|set(searchinfo["locales"][locale][region]["visibleDefaultEn
> gines"]))
> 17:27:12     INFO - KeyError: 'visibleDefaultEngines'
> 
> So we'll want a bug for that as well.
> 
> My sincerest apologies for the screw up.

It looks like that code is https://dxr.mozilla.org/mozilla-central/rev/6ff60a083701d08c52702daf50f28e8f46ae3a1c/python/mozbuild/mozbuild/action/output_searchplugins_list.py#15, which appears to be called by https://dxr.mozilla.org/mozilla-central/rev/6ff60a083701d08c52702daf50f28e8f46ae3a1c/browser/locales/Makefile.in#39. I'm not sure if $(shell) will check the return code.
Blocks: 1442738
Release note added to ESR52.7.1 in Nucleus
We're building a 52.7.1 release to address this issue, which we're aiming to have ready to ship by tomorrow. Thanks again for the report!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
I've managed to reproduce this bug on 52.7.0 esr (it build) using Windows 10 x64.

I can confirm that Search works as expected on 52.7.1 esr (20180313134936, it build) across platforms: Windows 10 x64, macOS 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1445628
The 52.7.1 release is now live and should be there when you check for updates. Thanks again for the report!
No longer blocks: 1445582
Depends on: 1445582
You need to log in before you can comment on or make changes to this bug.