Closed Bug 1445350 Opened 2 years ago Closed 2 years ago

browser_panelUINotifications_multiWindow.js fails on windows10 with new taskcluster worker

Categories

(Firefox :: Toolbars and Customization, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: jmaher, Assigned: Gijs)

References

Details

Attachments

(1 file)

updating our infrastructure/tooling to fix bugs/features we have a new worker which is responsible for accepting the tests to run and launching the mozharness/test script to run the tests.

The main difference in the new worker is that we login as an actual user instead of simulating it with runas and mapping directories.

While doing this we find that browser_panelUINotifications_multiWindow.js is failing for us consistently:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=85b4ef4fa06f4a75d9b50f8a3de2a3ecab3f7afd&filter-searchStr=10-64%20browser-chrome

looking at a debug log [1]:
22:06:58     INFO -  727 INFO TEST-START | browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js
22:06:58     INFO -  GECKO(1112) | ++DOCSHELL 000001DBB1D62000 == 2 [pid = 7468] [id = {e1c0cb68-dec2-46c2-8d5a-b5a7fba2941e}]
22:06:58     INFO -  GECKO(1112) | ++DOMWINDOW == 4 (000001DBB1B1C800) [pid = 7468] [serial = 36] [outer = 0000000000000000]
22:06:58     INFO -  GECKO(1112) | ++DOMWINDOW == 5 (000001DBB277F400) [pid = 7468] [serial = 37] [outer = 000001DBB1B1C800]
22:06:58     INFO -  GECKO(1112) | ++DOMWINDOW == 6 (000001DBB2780C00) [pid = 7468] [serial = 38] [outer = 000001DBB1B1C800]
22:06:58     INFO -  GECKO(1112) | ++DOCSHELL 000001D9413CE000 == 19 [pid = 1112] [id = {dd12a5f3-d225-4451-898b-7aac88385405}]
22:06:58     INFO -  GECKO(1112) | ++DOMWINDOW == 48 (000001D939625400) [pid = 1112] [serial = 300] [outer = 0000000000000000]
22:06:58     INFO -  GECKO(1112) | ++DOMWINDOW == 49 (000001D93A09A400) [pid = 1112] [serial = 301] [outer = 000001D939625400]
22:06:59     INFO -  GECKO(1112) | ++DOCSHELL 000001D941C2D000 == 20 [pid = 1112] [id = {46d79c13-70fc-4c16-9802-f1e3ecb16857}]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 50 (000001D93A418000) [pid = 1112] [serial = 302] [outer = 0000000000000000]
22:06:59     INFO -  GECKO(1112) | ++DOCSHELL 000001D941C2D800 == 21 [pid = 1112] [id = {db5ff910-a7d2-4e36-9021-5258c29fdb5f}]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 51 (000001D93A418800) [pid = 1112] [serial = 303] [outer = 0000000000000000]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 52 (000001D93A41A000) [pid = 1112] [serial = 304] [outer = 000001D93A418800]
22:06:59     INFO -  GECKO(1112) | ++DOCSHELL 00000221B4D40000 == 2 [pid = 4632] [id = {1087f229-49ee-4505-8fde-3871a196b658}]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 6 (00000221BC506C00) [pid = 4632] [serial = 161] [outer = 0000000000000000]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 7 (00000221BC50CC00) [pid = 4632] [serial = 162] [outer = 00000221BC506C00]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 53 (000001D93DB05800) [pid = 1112] [serial = 305] [outer = 000001D93A418000]
22:06:59     INFO -  GECKO(1112) | ++DOMWINDOW == 8 (00000221BC510000) [pid = 4632] [serial = 163] [outer = 00000221BC506C00]
22:06:59     INFO -  GECKO(1112) | --DOCSHELL 000001DBA9E3D000 == 1 [pid = 7468] [id = {9b6a835d-c2e7-46ab-8af8-8962ee0d6260}]
22:06:59     INFO -  TEST-INFO | started process screenshot
22:06:59     INFO -  TEST-INFO | screenshot: exit 0
22:06:59     INFO -  Buffered messages logged at 22:06:58
22:06:59     INFO -  728 INFO Entering test bound testDoesNotShowDoorhangerForBackgroundWindow
22:06:59     INFO -  Buffered messages finished
22:06:59    ERROR -  729 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js | The background window's doorhanger is closed. - Got showing, expected closed
22:06:59     INFO -  Stack trace:
22:06:59     INFO -  chrome://mochikit/content/browser-test.js:test_is:1271
22:06:59     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js:testDoesNotShowDoorhangerForBackgroundWindow/<:25
22:06:59     INFO -  Not taking screenshot here: see the one that was previously logged
22:06:59    ERROR -  730 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js | The background window has a badge. - Got false, expected true
22:06:59     INFO -  Stack trace:
22:06:59     INFO -  chrome://mochikit/content/browser-test.js:test_is:1271
22:06:59     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js:testDoesNotShowDoorhangerForBackgroundWindow/<:26
22:06:59     INFO -  GECKO(1112) | --DOMWINDOW == 5 (000001DBB1B1A800) [pid = 7468] [serial = 33] [outer = 0000000000000000] [url = about:blank]
22:06:59     INFO -  731 INFO TEST-PASS | browser/components/customizableui/test/browser_panelUINotifications_multiWindow.js | update-manual doorhanger is showing. -


this is the same failure on opt/debug and seems to be early in the test.



[1] https://taskcluster-artifacts.net/LBKHOPooTnG9hujvz0tc9Q/0/public/logs/live_backing.log
As all the other browser-chrome tests work, I am inclined to skip this on windows-10 in the short term.  Do you have concerns with that or suggestions of things to try?
Flags: needinfo?(gijskruitbosch+bugs)
Embarrassingly, this test has always failed for me locally on my win10 machine and I always just assumed it was something about my machine (maybe that it's hidpi), but given this maybe we can just actually fix the test (all the more because I can reproduce failures locally!).
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8958805 [details]
Bug 1445350 - fix browser_panelUINotifications_multiWindow.js so it doesn't fail on win10,

https://reviewboard.mozilla.org/r/227714/#review233506
Attachment #8958805 - Flags: review?(dothayer) → review+
Autolanding this whenever autoland autolands it (I've clicked the button). :jmaher, can you check if this helps you? :-)
Flags: needinfo?(jmaher)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/51b5d10855c9
fix browser_panelUINotifications_multiWindow.js so it doesn't fail on win10, r=dthayer
this appears to fix the problem, thanks!
Flags: needinfo?(jmaher)
https://hg.mozilla.org/mozilla-central/rev/51b5d10855c9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.