Closed Bug 1445366 Opened 6 years ago Closed 6 years ago

test_modal_prompt.html fails on windows10 with new taskcluster worker

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmaher, Unassigned)

References

Details

updating our infrastructure/tooling to fix bugs/features we have a new worker which is responsible for accepting the tests to run and launching the mozharness/test script to run the tests.

The main difference in the new worker is that we login as an actual user instead of simulating it with runas and mapping directories.

While doing this we find that toolkit/components/passwordmgr/test/mochitest/test_prompt.html is failing for us consistently:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=85b4ef4fa06f4a75d9b50f8a3de2a3ecab3f7afd&filter-searchStr=10-64%20mochitest-e10s-5&selectedJob=166562571


here is what I see in a log [1]:
19:57:01     INFO -  2379 INFO TEST-START | toolkit/components/prompts/test/test_modal_prompts.html
19:57:01     INFO -  2380 INFO TEST-PASS | toolkit/components/prompts/test/test_modal_prompts.html | Access Ci
19:57:01     INFO -  2381 INFO TEST-PASS | toolkit/components/prompts/test/test_modal_prompts.html | Access Cc
19:57:01     INFO -  2382 INFO SpawnTask.js | Entering test runPromptTests
19:57:01     INFO -  2383 INFO Process type: 2
19:57:01     INFO -  2384 INFO Running tests with: isTabModal=false, usePromptService=true
19:57:01     INFO -  2385 INFO TEST-PASS | toolkit/components/prompts/test/test_modal_prompts.html | Running tests (isTabModal=false, usePromptService=true)
19:57:01     INFO -  2386 INFO Starting test: Alert
20:03:11     INFO -  Buffered messages finished
20:03:11  WARNING -  TEST-UNEXPECTED-TIMEOUT | toolkit/components/prompts/test/test_modal_prompts.html | application timed out after 370 seconds with no output
20:03:11     INFO -  2387 ERROR Force-terminating active process(es).
20:03:11     INFO -  Determining child pids from psutil...

when I disable this, the next test in the manifest fails test_modal_select.html:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8c9e190b6376aed6b6b3167f03e36da8ce61d6c0&selectedJob=167715473&filter-searchStr=mochitest-e10s-5

this seems very similar to bug 1445356 which is for the password manager test_*prompt.html tests.




[1] https://taskcluster-artifacts.net/XVvQIqxzSSK-_yABwrpuUQ/0/public/logs/live_backing.log
:past, I see you are the triage owner for toolkit::general, can you help me find someone who knows more about these tests and can help suggest ways to fix them to run on windows10 properly?  I am happy to help try different debugging tricks on try.
Flags: needinfo?(past)
Component: General → Password Manager
Flags: needinfo?(past)
Matt should know more.
Flags: needinfo?(MattN+bmo)
I think there was a typo in comment 0 as this is for toolkit/components/prompts/test/test_modal_prompts.html which isn't password manager. Bug 1445356 was filed for test_prompt.html already.

I suspect all of these bugs have the same root cause which is probably at a lower level related to window-management and I don't think they all need to filed separately. Once it's reproducible locally, maybe someone who works on Windows widget code would be able to debug.
Component: Password Manager → General
Flags: needinfo?(MattN+bmo)
closing this bug as a fix to the generic worker resolved issues- any remaining issues with the tests are not related to the worker upgrade.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.