Minimize / Maximize / Close buttons not displayed correctly when using client side decorations on Firefox 60.0b3

RESOLVED DUPLICATE of bug 1443481

Status

()

defect
RESOLVED DUPLICATE of bug 1443481
a year ago
a year ago

People

(Reporter: j1095945, Unassigned)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Posted image FirefoxProblem.jpg
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180312152746

Steps to reproduce:

Hello, since I really wanted to try new CSD feature I downloaded Firefox 60.0b3. I enabled CSD, everything worked fine, titlebar disappeared, but the icons don't seem to look correct. I have a little customized Gnome Adwaita Dark theme (Nothing fancy, I only have custom override for Minimize / Maximize / Close buttons.) In all the apps it works properly, even on Firefox with SSD, but when i enable CSD all my "custom" icons have white minimize, maximize and close sign on top of them. I also enclose a screenshot. I am on 64 bit Linux, Gnome 3.22


Actual results:

Minimize / Maximize / Close buttons have another "set of icons" on top of them.


Expected results:

Minimize / Maximize / Close Buttons should look the same way as when using SSD.

Comment 1

a year ago
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1443481, fixed in nightly but not in 60.
(Reporter)

Comment 2

a year ago
Ok, sorry, I did not notice that bug :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1443481
You need to log in before you can comment on or make changes to this bug.