Strange number in the dialog text for an invalid certificate

VERIFIED DUPLICATE of bug 139561

Status

VERIFIED DUPLICATE of bug 139561
17 years ago
10 years ago

People

(Reporter: mscott, Assigned: ssaux)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I sent someone a signed message and for some reason they weren't able to
validate it. So they got a signed icon with a question mark over it. If you
click on the signed icon you get a dialog describing how the signature could not
be verified. 

At the very end of that sentence is an integer in parantheses: (1039)

That seems like a bug. 

I'll attach a screen shot.
(Reporter)

Comment 1

17 years ago
Created attachment 83585 [details]
screen shot showing the strange number
(Assignee)

Comment 2

17 years ago
the question mark is a feature (which will have better handling for RTM) It's
described in bug 139561 (can't verify the signature when large attachments are
not downloaded from the imap server).

The number is also probably a feature. For error we don't specifically handle,
we print the error number because from a support perspective it easier to track
and easier to document.  I'm assigning this to Kai so that he may comment it
there's a need, but I'm duping it to 139561.


*** This bug has been marked as a duplicate of 139561 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Hmm that sounds like a really strange feature. I think showing a random integer
string in the middle of some dialog text is going to generate more support calls
than not showing the integer. That really seems couter intuitive. Aren't they
going to wonder why this integer is there? I'm sure the UE teams don't like that
much.

The text already clearly states what's going on so can't they just describe the
text to the support person? I'll take that up in the bug you marked this a dup of. 

Comment 4

17 years ago
.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: S/MIME → Security: S/MIME
Product: PSM → Core

Updated

10 years ago
Version: psm1.01 → 1.0 Branch

Updated

10 years ago
Component: Security: S/MIME → Security: S/MIME
Product: Core → MailNews Core
QA Contact: carosendahl → s.mime
You need to log in before you can comment on or make changes to this bug.