Closed Bug 1445777 Opened 3 years ago Closed 3 years ago

Texts and fonts disappear from the web pages

Categories

(Firefox :: Untriaged, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1435472

People

(Reporter: hell0wnerz88, Unassigned)

Details

Attachments

(4 files, 1 obsolete file)

Attached image mbbhEny.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180310025718

Steps to reproduce:

After updating to the latest version, I recieved this issue with fonts and texts on web pages. I tried fresh install, tried gfx.direct2d.disabled to true, layers.omtp.enabled to false, nothing helped.


Actual results:

Can't see fonts and texts on web pages, unless I mouseover over them they start to apear one by one, I uploaded photo.


Expected results:

I should see texts load normally.
After updating to the latest version, it is happening to me also. Also images are concerned, some show after mouseover.

Tried everything found in internet, have latest video card drivers, turning off the hardware acceleration works, but i wish to understand the cause of this.

to see again the objects i have to analize the page and deselect the codelines where fonts are declared: doing so the page pops up correctly.
Attached image text missing
about:support information for affected user
I'm affected by this as well, with similar symptoms, on 2 different machines.

Machine 1: custom built desktop with nVidia GTX 1070, Win10 x64, Firefox 59
Machine 2: Macbook Pro 2015 with Boot Camp, Win10 x64, Firefox 59

I've attached about:support for Machine 1 to the ticket.

Here are desktop recording of the issue: https://youtu.be/mk7kZ35eKTI and https://youtu.be/u1j5Od1VJTc

In the longer video, I try selecting text as well as changing the zoom level.  Changing the zoom level often 'fixes' the problem, either partly or entirely, but only temporarily.  Continuing to change zoom levels can bring the issue back.

Using Safe Mode does not help.
Attached image firefox-bad-layering.png (obsolete) —
An example of Firefox performing layering incorrectly.  Black/white gradients are my additions to remove names and photos from the screenshot.  Observe the Message List dropdown from Facebook is showing the photo of a chicken underneath it, even though the photo should be occluded by the dropdown.
Attachment #8959746 - Attachment is obsolete: true
Apologies, previous attachment was a Paint.net file, not a PNG.
hi, thanks for reporting this. we are currently looking into this issue in bug 1435472

so far it appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. so a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in firefox:
https://support.mozilla.org/en-US/kb/performance-settings
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435472
You need to log in before you can comment on or make changes to this bug.