Closed Bug 1446110 Opened 2 years ago Closed 2 years ago

macos beta build "make partial mar failed" /tools/update-packaging/common.sh: line 207: : No such file or directory

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox61 fixed)

RESOLVED DUPLICATE of bug 1439860
Tracking Status
firefox61 --- fixed

People

(Reporter: wsmwk, Assigned: tomprince)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

fallout from Bug 1439860 - tools/update-packaging scripts need cleaning up for safety

https://archive.mozilla.org/pub/thunderbird/candidates/60.0b1-candidates/build1/logs/release-comm-beta-macosx64_build-bm84-build1-build31.txt.gz

========= Started 'make -C ...' (results: 0, elapsed: 3 secs) (at 2018-03-15 09:30:09.605893) =========
make -C objdir-tb/tools/update-packaging
 in dir /builds/slave/tb-rel-c-beta-m64_bld-00000000/build (timeout 1200 secs)
 watching logfiles {}
 argv: ['make', '-C', 'objdir-tb/tools/update-packaging']
 environment:
  Apple_PubSub_Socket_Render=/tmp/launch-OzamFa/Render
  BUILDBOTCUSTOM=https://hg.mozilla.org/build/buildbotcustom
 ...
MAR=../../dist/host/bin/mar \
	MOZ_PRODUCT_VERSION=60.0 \
	  /builds/slave/tb-rel-c-beta-m64_bld-00000000/build/mozilla/tools/update-packaging/make_full_update.sh \
	  '../../dist/update/mac/en-US/thunderbird-60.0b1.complete.mar' \
	  '/builds/slave/tb-rel-c-beta-m64_bld-00000000/build/objdir-tb/dist/thunderbird/Thunderbird.app'
/builds/slave/tb-rel-c-beta-m64_bld-00000000/build/objdir-tb/dist/thunderbird/Thunderbird.app /builds/slave/tb-rel-c-beta-m64_bld-00000000/build/objdir-tb/tools/update-packaging
usage: mktemp [-d] [-q] [-t prefix] [-u] template ...
       mktemp [-d] [-q] [-u] -t prefix 
/builds/slave/tb-rel-c-beta-m64_bld-00000000/build/mozilla/tools/update-packaging/common.sh: line 207: : No such file or directory
/builds/slave/tb-rel-c-beta-m64_bld-00000000/build/mozilla/tools/update-packaging/common.sh: line 197: : No such file or directory
/builds/slave/tb-rel-c-beta-m64_bld-00000000/build/objdir-tb/tools/update-packaging
Once this is reviewed, I think this should (in order):
1) land on the TB 60.0b1 relbranch and a build proceed with it
2) land on m-c
3) nominate for m-b, so that TB doesn't need to re-apply this for all esr60 builds (until those move to taskcluster)
Flags: needinfo?(jorgk)
Thanks, noted. Re. 3) For ESR 60 we use a permanent branch, so we only need to apply it once.
Flags: needinfo?(jorgk)
Comment on attachment 8959442 [details]
Bug 1446110: [update-packaging] Specify prefix for temporary files;

https://reviewboard.mozilla.org/r/228254/#review234148

Seems OK. Please avoid landing this on mozilla-central or the default branch of mozilla-beta until after the ongoing releases have shipped.
Attachment #8959442 - Flags: review?(bhearsum) → review+
Thanks, I'm going to take it to M-B's THUNDERBIRD600b1_2018031401_RELBRANCH.
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/4d434313555a
[update-packaging] Specify prefix for temporary files; r=bhearsum
https://hg.mozilla.org/mozilla-central/rev/4d434313555a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1443896
This will get fixed in upstream bug.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1439860
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.