Closed Bug 1446113 Opened 3 years ago Closed 3 years ago

Startup crash in NS_InitXPCOM2

Categories

(Core :: JavaScript: Internationalization API, defect, P1)

59 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1445524
Tracking Status
firefox59 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-cb093fb4-5788-4624-b780-81e0f0180315.
=============================================================

Mac crash seen while looking at 59 release crash stats: http://bit.ly/2piOPoH. Present in 58.0.2 but in smaller numbers. Comments mention crashing after an update. Moz crash reason: u_init() failed

Top 6 frames of crashing thread:

0 libmozglue.dylib MOZ_CrashOOL mfbt/Assertions.cpp:33
1 XUL NS_InitXPCOM2 xpcom/build/XPCOMInit.cpp:673
2 XUL XREMain::XRE_main toolkit/xre/nsAppRunner.cpp:1567
3 XUL XRE_main toolkit/xre/nsAppRunner.cpp:4933
4 firefox main browser/app/nsBrowserApp.cpp:231
5 firefox start 

=============================================================
It sounds like this is related to the initialization of the internationalization library.
Component: XPCOM → JavaScript: Internationalization API
See Also: → 1445524
I'd lay fair odds on folding ICU's data file directly into the binary fixing, or at least ameliorating, this.  But just knowing u_init failed says effectively nothing to help with debugging whatever's specifically happening here.
Jeff, is there a bug for that? How can we get a better error message when this occurs?
Flags: needinfo?(jwalden+bmo)
Found it, bug 1445524. Hmm. Leaving this open as a P1.
Flags: needinfo?(jwalden+bmo)
Priority: -- → P1
Jeff, was this in fact fixed as foretold in comment 2? Is it too early to tell? etc.
Flags: needinfo?(jwalden+bmo)
Too early, seems like.  I'd give it a week or two then loop back.
Flags: needinfo?(jwalden+bmo)
The desktop crashes appear to be gone as of the 3-28 build. There are still a few Fennec crashes in nightly, including one crash in 20180403100100.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I closed this prematurely. Still investigating.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We still have some crashes on Beta and Nightly with this signature and moz_crash_reason= "u_init() failed": https://bit.ly/2Lrjiew

However, the number of crahes is way down from the spike in 58, so closing this one.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1445524
You need to log in before you can comment on or make changes to this bug.