Mozilla CRASHes when opening up "maps.yahoo.com" with a specific address

VERIFIED DUPLICATE of bug 85958

Status

()

Core
Plug-ins
P2
critical
VERIFIED DUPLICATE of bug 85958
16 years ago
16 years ago

People

(Reporter: Alejandro Medrano, Assigned: serge (gone))

Tracking

({crash, regression})

Trunk
mozilla1.0
Sun
SunOS
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc2) Gecko/20020513
BuildID:    0000000000

In the console where Mozilla was started, I always get this output when I
encounter this particular crash:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (MIT-SHM)
  Minor opcode of failed request:  3 (X_ShmPutImage)
  Serial number of failed request:  56
  Current serial number in output stream:  56



Reproducible: Always
Steps to Reproduce:
Assuming that you have a "My Yahoo" account that has a "maps" channel
1.Choose an address from the "Recently Used" list, or
  enter an address in the fields provided
2.Click "Get Map"
3.Mozilla dissapears

Did not see the problem with RC1.  I am using:

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc2) Gecko/20020513

Comment 1

16 years ago
I can confirm this crash on Sparc Solaris with trunk build 2002051922. I also
see it in the RC2 builds.

This problem is related to the Flash plugin. It happens on any Flash page
(www.macromedia.com and www.adobe.com are some other examples) that I try and
it goes away if I move the Flash plugin out of the way.

My guess is that the patch to bug 118846 caused this.  I'll make a note over
there. I'll also try to narrow down when this bug showed up in nightlies.
Status: UNCONFIRMED → NEW
Component: XP Apps → Plug-ins
Ever confirmed: true
Keywords: crash, regression

Comment 2

16 years ago
Have you tried reducing the shared memory buffer back to 64k?

Just change the line in run-mozilla.sh from:
 XSUNSMESIZE="512"

to 
  XSUNSMESIZE="64"

and see if it still crashes.

Comment 3

16 years ago
I just installed the Flash plugin and reduced shared memory back to 64 with:

XSUNSMESIZE="64"

and it still crashes for me with:

mila{jwasilko}141: ./run-mozilla.sh 
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (MIT-SHM)
  Minor opcode of failed request:  3 (X_ShmPutImage)
  Serial number of failed request:  67
  Current serial number in output stream:  67

So I don't think the patch for bug 118846 has anything to do with this. Looks
like the flash plugin is busted.

Comment 4

16 years ago
Ok, this actually looks to me like it might be a duplicate of bug 85958. 

Reporter, do you get crashes with all pages containing flash - e.g.
www.macromedia.com, www.adobe.com?  Also, could you double check to see if you
RC1 gives you crashes? 

Comment 5

16 years ago
-> default owner
Assignee: sgehani → beppe
QA Contact: paw → shrir

Comment 6

16 years ago
handing over to serge for review and verify
Assignee: beppe → serge
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 7

16 years ago
I can not reproduce the bug with Netscape7.0b1 on solaris 8.

(Assignee)

Comment 8

16 years ago
most likely this is a dup of bug 85958

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 85958 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.