Cannot paste text from buffer-cut xclipboard

RESOLVED DUPLICATE of bug 1447925

Status

()

defect
RESOLVED DUPLICATE of bug 1447925
a year ago
a year ago

People

(Reporter: rob.pumphrey, Unassigned)

Tracking

59 Branch
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180310025718

Steps to reproduce:

Using Debian Jessie amd64. Run 3 terminals in x session with the following commands:
watch -n1 xclip -o -selection primary
watch -n1 xclip -o -selection clipboard
watch -n1 xclip -o -selection buffer-cut
Highlight text in firefox, text highlighted is show in xclip primary and can be pasted back into firefox with middle click
Highlight text in firefox and Ctrl-C, text highlighted is show in xclip primary and clipboard and can be pasted into firefox with middle click or CTRL-V
Highlight text in remote VNC window, xclip primary and xclip clipboard now show empty values and the text highlighted is show in xclip buffer-cut. Neither middle click or CTRL-V will paste the content of the buffer-cut into firefox 

This usecase was working in Firefox 58.0.2 although I have not reinstalled 58.0.2 and confirmed that the buffers were working in exactly the same way.


Actual results:

Text in the buffer-cut xclipboard is not pasted into firefox. Cannot paste text into URL bar, or text field/text area.


Expected results:

Text in buffer-cut xclipbard buffer should be pasted into firefox
Reporter

Comment 1

a year ago
Confirmed this is a change in behaviour between version 58.0.2 and 59.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446785

Comment 3

a year ago
I can confirm this bug, but I don't think it's a duplicate of #1446785.

The steps in #1446785 does not reproduce this bug for me, but copying text into a VNC session does not work with firefox, but does with eg. a text editor. Copying the text locally on the VNC host works fine in firefox. And it definatelly happened in 59.0.

Have not tested with nightly though.

Comment 4

a year ago
Can reproduce the bug in Firefox 61.0a Nightly (downloaded March 26).
Reporter

Comment 5

a year ago
I have also reproduced this in Firefox 61.0a Nightly downloaded 26th March and also do not think it is the same issue as #1446785.
@rob, given that this change happened somewhere between 58 and 59, could you please try to find a regression range using Mozregression tool?
Information on the tool is available at http://mozilla.github.io/mozregression/.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(rob.pumphrey)
Resolution: DUPLICATE → ---
Reporter

Comment 7

a year ago
I have run the Mozregression tool and got the following answer. 

The commit message looks promising.

2018-04-05T12:18:06: INFO : Narrowed inbound regression window from [463d676d, c9c66aa3] (3 builds) to [463d676d, 296dd5f8] (2 builds) (~1 steps left)
2018-04-05T12:18:06: DEBUG : Starting merge handling...
2018-04-05T12:18:06: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=296dd5f8849a593383d991338a82024aac46b546&full=1
2018-04-05T12:18:07: DEBUG : Found commit message:
Bug 1417874 - Split clipboard implementation to shared (nsClipboard) and backend specific (nsClipboardX11) parts, r=jhorak

MozReview-Commit-ID: 5IebGayJl1

2018-04-05T12:18:07: INFO : The bisection is done.
Flags: needinfo?(rob.pumphrey)
@stransky, could you please take a look at this?
Blocks: 1417874
Status: REOPENED → NEW
Component: Untriaged → Widget: Gtk
Flags: needinfo?(stransky)
OS: Unspecified → Linux
Product: Firefox → Core
Can you please check latest nightly? It can be Bug 1447925.
Flags: needinfo?(stransky) → needinfo?(rob.pumphrey)

Comment 10

a year ago
Works in newest nightly (atleast for me)
Reporter

Comment 11

a year ago
Fixed for me in the latest nightly. Thanks v. much. Excellent response from you all.
Flags: needinfo?(rob.pumphrey)
Thanks. I'll request uplift Bug 1447925 to FF60 (and ESR) to fix that ASAP.
Status: NEW → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1447925
You need to log in before you can comment on or make changes to this bug.