Fullscreen on a video causes mouse cursor to be visible until wiggled

RESOLVED DUPLICATE of bug 1437941

Status

()

defect
RESOLVED DUPLICATE of bug 1437941
Last year
Last year

People

(Reporter: ililil.zac, Unassigned)

Tracking

59 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180315233128

Steps to reproduce:

1. Open a video (YouTube, Netflix, etc)
2. Press the fullscreen button (or press F) and do not move the mouse


Actual results:

The mouse cursor stays on the screen until it is wiggled (it hides after a few seconds once wiggled).


Expected results:

Cursor should disappear as soon as the video is made fullscreen.
I should note, this happens on my laptop which uses Windows scalling, and does not happen on my computer which does not use scalling. Don't know if that is the reason it is happening but hope it helps.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Hi Isaac, thanks for reporting this issue.

I wasn't able to reproduce the issue on Windows 10 x64. 
When going on fullscreen on Youtube using the fullscreen button, the mouse cursor is no longer displayed. 
When going on fullscreen on Youtube using the "F" key, the mouse cursor is only displayed while the top notification (regarding the exit from fullscreen) is displayed. After that, the mouse cursor is no longer displayed.

Must note that I tried these scenarios with both scaled (125%) and unscaled setting and the behavior was the same described above. 

Could you please retest this issue using a new clean Firefox profile (https://goo.gl/7Fec9d), maybe even safe mode (https://goo.gl/AR5o9d), to eliminate custom settings as a possible cause?

Thanks!
Flags: needinfo?(ililil.zac)
Hi,
I tried making a new profile and using safe-mode but I still have the same issue. I cannot reproduce this on computer either, only my laptop. 
I can't think of any reason why this should be happening. I read on past bug reports of people having the same issue but that was years ago (example: https://bugzilla.mozilla.org/show_bug.cgi?id=1273091 ).
I do not have the issue in other browsers such as Chrome.
Thanks.
Flags: needinfo?(ililil.zac)
It seems that this is a regression and it's already tracked in 1437941.
Closing this as a duplicate in favor of 1437941.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1437941
You need to log in before you can comment on or make changes to this bug.