Closed Bug 1446728 Opened 3 years ago Closed 3 years ago

360 video plays only audio

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

Firefox 59
defect
Not set
normal

Tracking

(fennec?, firefox59 affected, firefox60 affected, firefox61 affected, firefox62 affected, firefox63 affected)

RESOLVED DUPLICATE of bug 1486659
Tracking Status
fennec ? ---
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: erez.bouskila, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

Steps to reproduce:

Hi,

After v59 came out I tested with this linkhttp://www.kaltura.com/index.php/extwidget/preview/partner_id/1900001/uiconf_id/38956021/entry_id/0_o4gnhsf7/embed/dynamic

Only the audio plays and the video is black, I get the following error in the console:
"Error: WebGL warning: texImage2D: GetAsSourceSurface or GetDataSurface failed after blit failed for TexUnpackImage."

It was said in https://bugzilla.mozilla.org/show_bug.cgi?id=1434504 that this would be fixed in v59 but it still happens, also I tested with nightly v61 and got the same result.


Actual results:

Only the audio plays and the video is black


Expected results:

The audio should play and the 360 video should be displayed.
(In reply to Erez.b from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3)
> AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
> 
> Steps to reproduce:
> 
> Hi,
> 
> After v59 came out I tested with this
> linkhttp://www.kaltura.com/index.php/extwidget/preview/partner_id/1900001/
> uiconf_id/38956021/entry_id/0_o4gnhsf7/embed/dynamic
> 
> Only the audio plays and the video is black, I get the following error in
> the console:
> "Error: WebGL warning: texImage2D: GetAsSourceSurface or GetDataSurface
> failed after blit failed for TexUnpackImage."
> 
> It was said in https://bugzilla.mozilla.org/show_bug.cgi?id=1434504 that
> this would be fixed in v59 but it still happens, also I tested with nightly
> v61 and got the same result.
> 
> 
> Actual results:
> 
> Only the audio plays and the video is black
> 
> 
> Expected results:
> 
> The audio should play and the 360 video should be displayed.

Go to about:config page and then set the 'layers.acceleration.disabled' to 'true' and then try it.If the problem still persists,reply here.
Denesh Thanks for the quick reply. I changed it to true but it still happens.
tracking-fennec: --- → ?
@Denesh @Michael any update on this issue?
Thanks
(In reply to Denesh from comment #1)
> (In reply to Erez.b from comment #0)
> > User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3)
> > AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
> > 
> > Steps to reproduce:
> > 
> > Hi,
> > 
> > After v59 came out I tested with this
> > linkhttp://www.kaltura.com/index.php/extwidget/preview/partner_id/1900001/
> > uiconf_id/38956021/entry_id/0_o4gnhsf7/embed/dynamic
> > 
> > Only the audio plays and the video is black, I get the following error in
> > the console:
> > "Error: WebGL warning: texImage2D: GetAsSourceSurface or GetDataSurface
> > failed after blit failed for TexUnpackImage."
> > 
> > It was said in https://bugzilla.mozilla.org/show_bug.cgi?id=1434504 that
> > this would be fixed in v59 but it still happens, also I tested with nightly
> > v61 and got the same result.
> > 
> > 
> > Actual results:
> > 
> > Only the audio plays and the video is black
> > 
> > 
> > Expected results:
> > 
> > The audio should play and the 360 video should be displayed.
> 
> Go to about:config page and then set the 'layers.acceleration.disabled' to
> 'true' and then try it.If the problem still persists,reply here.

The issue is still not fix, is there any update?
I could reproduce the issue on the latest Nightly 61 build (2018-04-11).
Note that it's not a permanent issue, the problem can be fixed sometimes by restarting the browser or a Clear data on the app. It will appear again though if you close and reopen the page.

Devices:
Huawei Nexus 6P (Android 8.0)
Sony Xperia Z5 Premium (Android 6.0.1)
Huawei Honor 8 (Android 7.0)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Oana Horvath from comment #5)
> I could reproduce the issue on the latest Nightly 61 build (2018-04-11).
> Note that it's not a permanent issue, the problem can be fixed sometimes by
> restarting the browser or a Clear data on the app. It will appear again
> though if you close and reopen the page.
> 
> Devices:
> Huawei Nexus 6P (Android 8.0)
> Sony Xperia Z5 Premium (Android 6.0.1)
> Huawei Honor 8 (Android 7.0)

Thanks for the update, unfortunately I cannot go back to our customer who is effected by this issue and provide them with the restarting the browser or a Clear data on the app workaround as a fix.

Is there a plan to fix this issue?
Is there any update about this issue?
(In reply to Oana Horvath from comment #5)
> I could reproduce the issue on the latest Nightly 61 build (2018-04-11).
> Note that it's not a permanent issue, the problem can be fixed sometimes by
> restarting the browser or a Clear data on the app. It will appear again
> though if you close and reopen the page.
> 
> Devices:
> Huawei Nexus 6P (Android 8.0)
> Sony Xperia Z5 Premium (Android 6.0.1)
> Huawei Honor 8 (Android 7.0)

Any update to this issue?
Thanks
(In reply to Oana Horvath from comment #5)
> I could reproduce the issue on the latest Nightly 61 build (2018-04-11).
> Note that it's not a permanent issue, the problem can be fixed sometimes by
> restarting the browser or a Clear data on the app. It will appear again
> though if you close and reopen the page.
> 
> Devices:
> Huawei Nexus 6P (Android 8.0)
> Sony Xperia Z5 Premium (Android 6.0.1)
> Huawei Honor 8 (Android 7.0)

Any updates in regards to this matter?
Or if they are any plans to fix the caching issues?
Duplicate of this bug: 1470722
Hi, is there any updates in regards to this matter.
Hi @Denesh @Oana Horvath @sorina
Any updates in regards to this issue? and is there any way I can provide you with additional info?
@Susheel or @Sebastian, I'm not sure who to NI here. Could this be triaged and set a priority or is anyone working actively on this side? Thanks!
Flags: needinfo?(sdaswani)
Flags: needinfo?(s.kaspari)
Oana I'm wary to have the Softvision Devs take a look at this since it could be video encoding related, but I have put it on their work list for triage.
Flags: needinfo?(sdaswani)
Flags: needinfo?(s.kaspari)
Whiteboard: [priority:medium]
Hi, are they any updates in regards to this matter?
Hi @Denesh @Oana Horvath @sorina
Any updates in regards to this issue?
(In reply to Shalom from comment #16)
> Hi @Denesh @Oana Horvath @sorina
> Any updates in regards to this issue?

Hi,
No updates. The bug is on the devs' radar, as you can see from #comment14, but there are other issues with higher priority at the moment. You will be able to see the bug status change to "Resolved Fixed" when it's ready. Thank you!
Thank you.
Managed to reproduce, however this seems to me like a Gecko issue, posting my findings below:

>> 08-31 18:09:08.671 8468-8657/org.mozilla.fennec_vlad.baicu W/GeckoConsole: [JavaScript Warning: "Use of the motion sensor is deprecated." {file: "http://cdnapi.kaltura.com/html5/html5lib/v2.56/load.php?debug=false&lang=en&modules=Hlsjs%2CacCheck%2CacPreview%2Cbase64_decode%2Cbase64_encode%2Cclass%2CcontrolBarContainer%2CcurrentTimeLabel%2CdurationLabel%2CfullScreenBtn%2Cid3Tag%2CkAnalony%2Ckdark%2CkeyboardShortcuts%2CkgitGuard%2ClargePlayBtn%2CliveAnalytics%2CliveStream%2Clogo%2CmatchMedia%2CmorePlugins%2CnativeBridge%2CplayPauseBtn%2Cplayerjs%2Cpolyfill_Array_filter%2CqualitySettings%2CreportError%2Cscreenfull%2Cscrubber%2CsideBarContainer%2Cstatist" line: 7}]
>> 08-31 18:09:08.729 8468-8657/org.mozilla.fennec_vlad.baicu W/GeckoConsole: [JavaScript Warning: "Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted." {file: "http://www.kaltura.com/index.php/extwidget/preview/partner_id/1900001/uiconf_id/38956021/entry_id/0_o4gnhsf7/embed/dynamic" line: 0}]
>> 08-31 18:09:08.730 8468-8657/org.mozilla.fennec_vlad.baicu E/GeckoConsole: [JavaScript Error: "NotAllowedError: The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission."]
>> 08-31 18:09:09.214 8468-8657/org.mozilla.fennec_vlad.baicu W/GeckoConsole: [JavaScript Warning: "Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted." {file: "http://www.kaltura.com/index.php/extwidget/preview/partner_id/1900001/uiconf_id/38956021/entry_id/0_o4gnhsf7/embed/dynamic" line: 0}]
>> 08-31 18:09:09.219 8468-8657/org.mozilla.fennec_vlad.baicu E/GeckoConsole: [JavaScript Error: "NotAllowedError: The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.”]

And a spam of these:

>> 08-31 18:11:12.653 8468-8657/org.mozilla.fennec_vlad.baicu E/GLConsumer: [SurfaceTexture-0-8468-8] attachToContext: GLConsumer is already attached to a context
>> 08-31 18:11:12.653 8468-8657/org.mozilla.fennec_vlad.baicu W/System.err: java.lang.RuntimeException: Error during attachToGLContext (see logcat for details)
>>         at android.graphics.SurfaceTexture.attachToGLContext(SurfaceTexture.java:289)
>>         at org.mozilla.gecko.gfx.GeckoSurfaceTexture.attachToGLContext(GeckoSurfaceTexture.java:84)
>>         at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
>>         at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:504)

NI-ing Susheel on this, maybe he can find someone that can take a look at this

Also, the video worked on the first try, starting with the second attempt, the reported issue appeared
Flags: needinfo?(sdaswani)
Punting to James.
Flags: needinfo?(sdaswani) → needinfo?(snorp)
This is essentially a dup of 1486659
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(snorp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1486659
Whiteboard: [priority:medium]
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.