Closed Bug 1447085 Opened 2 years ago Closed Last year

Netflix videos can't be played if the user checks "Never remember history" option

Categories

(Core :: Audio/Video: Playback, defect, P2)

60 Branch
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: igor.avramovic, Unassigned)

References

Details

Attachments

(2 files)

Attached image netflixerror.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180315232954

Steps to reproduce:

Playback error. I try to start video. I am using 60.0b4 (64-bit)


Actual results:

After the last update, Netflis will not work. Here is picture http://prntscr.com/itf0l3


Expected results:

It was supposed to start the movie
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Hi Igor, thanks for reporting this issue.

I have tried to reproduce this issue on Firefox Beta 60.0b4 and 60.0b5, on Windows 10 x64, but I haven't managed to reproduce it.

The following videos are playing correctly and no error is displayed:
- https://www.netflix.com/watch/80204923?trackId=14170287&tctx=0%2C0%2C115e92ab-f0c5-4aa6-bf6c-9bdec262e8f4-19289775%2Cba9f8522-bd88-4939-87f0-fa5492ceb3d9_24504804X3XX1521726458975%2Cba9f8522-bd88-4939-87f0-fa5492ceb3d9_ROOT
- https://www.netflix.com/watch/80017535?trackId=250326522&tctx=0%2C0%2Ca81660df-1335-447f-9459-7eb8b563df56-127999%2C1b9b6be5-52ec-4df0-b7f1-faf6a2994c70_801051%2C1b9b6be5-52ec-4df0-b7f1-faf6a2994c70_ROOT
- https://www.netflix.com/watch/80049212?trackId=250324714&tctx=6%2C2%2Cec9f4e29-d8ba-4021-b87a-379beb73fb07-20744289%2C276d886e-6e6f-4ede-a652-824615e8447b_1417333%2C276d886e-6e6f-4ede-a652-824615e8447b_ROOT

Is this error shown on all videos from Netflix or just for some of them? If this is only happening with a few videos, can you give me the links to them?

Could you please retest this using the latest Nightly build and report back the results? (You can download the latest Nightly build from here https://goo.gl/57dpxn)
When doing this, please use a new clean Firefox profile (https://goo.gl/7ResgJ), maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/AR5o9d).

Thanks.
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(igor.avramovic)
Product: Firefox → Core
(In reply to Carmen Fat [:carmenf] from comment #1)
> User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0)
> Gecko/20100101 Firefox/60.0
> 
> Hi Igor, thanks for reporting this issue.
> 
> I have tried to reproduce this issue on Firefox Beta 60.0b4 and 60.0b5, on
> Windows 10 x64, but I haven't managed to reproduce it.
> 
> The following videos are playing correctly and no error is displayed:
> -
> https://www.netflix.com/watch/
> 80204923?trackId=14170287&tctx=0%2C0%2C115e92ab-f0c5-4aa6-bf6c-9bdec262e8f4-
> 19289775%2Cba9f8522-bd88-4939-87f0-
> fa5492ceb3d9_24504804X3XX1521726458975%2Cba9f8522-bd88-4939-87f0-
> fa5492ceb3d9_ROOT
> -
> https://www.netflix.com/watch/
> 80017535?trackId=250326522&tctx=0%2C0%2Ca81660df-1335-447f-9459-7eb8b563df56-
> 127999%2C1b9b6be5-52ec-4df0-b7f1-faf6a2994c70_801051%2C1b9b6be5-52ec-4df0-
> b7f1-faf6a2994c70_ROOT
> -
> https://www.netflix.com/watch/
> 80049212?trackId=250324714&tctx=6%2C2%2Cec9f4e29-d8ba-4021-b87a-379beb73fb07-
> 20744289%2C276d886e-6e6f-4ede-a652-824615e8447b_1417333%2C276d886e-6e6f-4ede-
> a652-824615e8447b_ROOT
> 
> Is this error shown on all videos from Netflix or just for some of them? If
> this is only happening with a few videos, can you give me the links to them?
> 
> Could you please retest this using the latest Nightly build and report back
> the results? (You can download the latest Nightly build from here
> https://goo.gl/57dpxn)
> When doing this, please use a new clean Firefox profile
> (https://goo.gl/7ResgJ), maybe even safe mode, to eliminate custom settings
> as a possible cause (https://goo.gl/AR5o9d).
> 
> Thanks.

I found out where the error was. The error occurs when I choose not to remember history: http://prntscr.com/iv85d6

I do not know if it's a bug or it should be like that.

Thanks
Flags: needinfo?(igor.avramovic)
(In reply to Igor from comment #2)
> (In reply to Carmen Fat [:carmenf] from comment #1)
> > User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0)
> > Gecko/20100101 Firefox/60.0
> > 
> > Hi Igor, thanks for reporting this issue.
> > 
> > I have tried to reproduce this issue on Firefox Beta 60.0b4 and 60.0b5, on
> > Windows 10 x64, but I haven't managed to reproduce it.
> > 
> > The following videos are playing correctly and no error is displayed:
> > -
> > https://www.netflix.com/watch/
> > 80204923?trackId=14170287&tctx=0%2C0%2C115e92ab-f0c5-4aa6-bf6c-9bdec262e8f4-
> > 19289775%2Cba9f8522-bd88-4939-87f0-
> > fa5492ceb3d9_24504804X3XX1521726458975%2Cba9f8522-bd88-4939-87f0-
> > fa5492ceb3d9_ROOT
> > -
> > https://www.netflix.com/watch/
> > 80017535?trackId=250326522&tctx=0%2C0%2Ca81660df-1335-447f-9459-7eb8b563df56-
> > 127999%2C1b9b6be5-52ec-4df0-b7f1-faf6a2994c70_801051%2C1b9b6be5-52ec-4df0-
> > b7f1-faf6a2994c70_ROOT
> > -
> > https://www.netflix.com/watch/
> > 80049212?trackId=250324714&tctx=6%2C2%2Cec9f4e29-d8ba-4021-b87a-379beb73fb07-
> > 20744289%2C276d886e-6e6f-4ede-a652-824615e8447b_1417333%2C276d886e-6e6f-4ede-
> > a652-824615e8447b_ROOT
> > 
> > Is this error shown on all videos from Netflix or just for some of them? If
> > this is only happening with a few videos, can you give me the links to them?
> > 
> > Could you please retest this using the latest Nightly build and report back
> > the results? (You can download the latest Nightly build from here
> > https://goo.gl/57dpxn)
> > When doing this, please use a new clean Firefox profile
> > (https://goo.gl/7ResgJ), maybe even safe mode, to eliminate custom settings
> > as a possible cause (https://goo.gl/AR5o9d).
> > 
> > Thanks.
> 
> I found out where the error was. The error occurs when I choose not to
> remember history: http://prntscr.com/iv85d6
> 
> I do not know if it's a bug or it should be like that.

When I allow history, netfliks work
> 
> Thanks
I was able to reproduce the issue after changing the "Remember history" to "Never remember history" option from "about:preferences" page. The issue is reproducible across platforms (Windows, Arch Linux, and macOS) and affects all channels.

Attached is a screenshot of the errors in browser console when trying to play videos with "Never remember history" option set.
Status: UNCONFIRMED → NEW
Component: Audio/Video: Playback → Preferences
Ever confirmed: true
Product: Core → Firefox
See Also: → 653826
Summary: Netflix error → Netflix videos can't be played if the user checks "Never remember history" option
Component: Preferences → Audio/Video: Playback
Product: Firefox → Core
Priority: -- → P2
According to the final decision in bug1334111 comment11, we decide to reject the request of navigator.requestMediaKeySystemAccess(). 

Mark this bug as INVALID because we don't allows website to get persistentState in private browsing.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
See Also: → 1334111
Setting "Never remember history" is equal to being the private browsing mode. [1]

[1] https://support.mozilla.org/en-US/kb/settings-privacy-browsing-history-do-not-track#w_never-remember-history
You need to log in before you can comment on or make changes to this bug.