Closed Bug 1447333 Opened 2 years ago Closed 2 years ago

Crash in static js::jit::EnterJitStatus EnterJit

Categories

(Core :: JavaScript Engine: JIT, defect, critical)

59 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1425132

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-6112f871-62ea-47f4-aa19-198770180317.
=============================================================

Seen while looking at nightly crash data: http://bit.ly/2ptlb07. Windows JS crash which appears to have started in Build 20180313100127. This signature is only seen in 61 nightly.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fdd1a0082c71673239fc2f3a6a93de889c07a1be&tochange=c56ef1c14a555023949ad727c86e3c2df995edd2

jdemooij seems to have worked in this code area. ni on him.

Top 10 frames of crashing thread:

0  @0x13cd4bff160 
1  @0x13cd4bff890 
2  @0x241d3437e7f 
3  @0x13cd4bff890 
4  @0x241c6138c17 
5  @0x13cd427156e 
6 xul.dll static js::jit::EnterJitStatus EnterJit js/src/jit/Jit.cpp:99
7 xul.dll js::jit::MaybeEnterJit js/src/jit/Jit.cpp:163
8 xul.dll static bool Interpret js/src/vm/Interpreter.cpp:3114
9 xul.dll js::RunScript js/src/vm/Interpreter.cpp:417

=============================================================
Flags: needinfo?(jdemooij)
This is more than likely to be another signature for the EnterBaseline function which got renamed to merge entry points into the JIT compiled code in Bug 1407607.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1425132
Flags: needinfo?(jdemooij)
You need to log in before you can comment on or make changes to this bug.