Closed Bug 1447403 Opened 2 years ago Closed 2 years ago

webrender: sketchfab models appear with checkerboard overlay on macOS

Categories

(Core :: Graphics: WebRender, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1447245

People

(Reporter: bradwerth, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Attached image webrender off.png
https://sketchfab.com/models/a21782443b2b41d98499c2836c10f67d

With webrender on macOS, the 3D model loads with an overlaid checkerboard pattern. When webrender is turned off, the model is shown correctly.

Interestingly, even when webrender is on, Firefox Screenshots captures the image correctly. The supplied "webrender on" attachment was taken with the macOS Grab tool to take the screen pixels directly.
Attached image webrender on.png
Nightly 61 x64 20180320100122 de_DE @ Debian Testing (KDE, Radeon RX480)
WFM.

This might be a duplicate of bug 1447245. Does this have the same regression range?
> Last good revision: 5f14c440b68aa1842822ac6d22f8bab8b7b1c89a
mozregression --repo autoland --launch 5f14c440b68aa1842822ac6d22f8bab8b7b1c89a --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://sketchfab.com/models/a21782443b2b41d98499c2836c10f67d"

> First bad revision: db3858c71406fa3929322e93e14bf225ebadb398
mozregression --repo autoland --launch db3858c71406fa3929322e93e14bf225ebadb398 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://sketchfab.com/models/a21782443b2b41d98499c2836c10f67d"
Version: unspecified → Trunk
This seems to be OK on Windows?
Priority: -- → P2
Can you still reproduce? bug 1447245 was fixed.
Flags: needinfo?(bwerth)
I can no longer reproduce. Great!
Flags: needinfo?(bwerth)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1447245
You need to log in before you can comment on or make changes to this bug.