Spellchecker freezes Mozzila

VERIFIED INVALID

Status

MailNews Core
Composition
--
critical
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: Leo H, Assigned: varada)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

Clicking on "Spell" after composing a message (or having automatic spellchecking
enabled in the preferences and then trying to send a message), freezes the
application.  The Windows Task Manager says that Mozilla uses 100% CPU time, and
I have to kill the Mozilla process.
I restarted Mozilla and tried to compose various messages, each time killing the
app when I go to spell.
I used to have a spellchecker installed using a downloaded xpi several versions
of Mozilla ago.  Could that be causing some problems?  Can I reinstall Mozilla
from scratch to make sure no old downloaded .xpi are causing problems?

Reproducible: Always
Steps to Reproduce:
1. Compose a message
2. Click on "Spell" button or chose "Check Spelling" from Options menu



Actual Results:  Mozilla freezes, taking up 100% CPU
Reassign to varada. Varada, please take a look at it asap...
Assignee: ducarroz → varada
Keywords: hang
(Assignee)

Comment 2

16 years ago
I am using a build from 20020512 and I am not able to reproduce this problem.
Leo do you know what build you were using earlier - I could try to go thru the
same steps.
(Reporter)

Comment 3

16 years ago
I'm sorry - it looks like I had an old spellchecker from
spellchecker.mozdev.org, which I forgot about, and it was freezing Mozilla.  I
thought that Mozilla RC2 shipped with a new spellchecker... therefor my
confusion.  I appologize.
I deleted all the Mozilla files, reinstalled Mozilla, the spellchecker in now
completely gone, and therefor the problem with it. :)
Thank you for your immediate attention and great work!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.