Screenshots and Report Site Issue... items in the Page Actions menu no longer show icons on the latest Nightly

RESOLVED DUPLICATE of bug 1449200

Status

defect
RESOLVED DUPLICATE of bug 1449200
a year ago
11 months ago

People

(Reporter: cmuresan, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

[Regression]:
- This issue is not reproducible with latest Firefox 58.0.0, Beta or yesterday's Nightly. Considering this I have performed a regression in order to find which bug introduced this. Here are the results:

Last good revision: 1aeb1fc7be3371280a5d6f93394d6df0d8db0ad2
First bad revision: 563f8e0d9d2dbf0eec8cb3f4afa0272f873e52ff
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1aeb1fc7be3371280a5d6f93394d6df0d8db0ad2&tochange=563f8e0d9d2dbf0eec8cb3f4afa0272f873e52ff

Looks like Bug 1446250 introduce this issue. 

[Affected versions]:
- Nightly 61.0a1
- Screenshots 31.1.0

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new Firefox profile.

[Steps to reproduce]:
1. Start the browser with the prerequisites from prerequisites.
2. Click the "..." page actions menu.
3. Observe the "Take a screenshot" option. 

[Expected result]:
- An icon is displayed in front of the string.

[Actual results]:
- No icon is displayed.

[Notes]:
- I wasn't able to reproduce this issue on a MacBook Pro retina display laptop, however I was able to reproduce it on an older iMac.
- Attached a screen shot with the issue.
Kris, could you please take a look at this?
Flags: needinfo?(kmaglione+bmo)

Comment 2

a year ago
Are there no automated tests that we run for screenshots in m-c that can catch this? We really ought to have some...
Flags: needinfo?(jhirsch)
Flags: in-testsuite?

Comment 3

a year ago
Oh, from the summary I assumed the page action was entirely gone. Updated the summary to be more clear. Less sure the icon is worth testing in detail...
Flags: needinfo?(jhirsch)
Summary: Screenshots icon from the Page Actions menu is no longer displayed on the latest Nightly → Screenshots item in the Page Actions menu no longer shows an icon on the latest Nightly
I'm not seeing this on current Nightly builds on Win10. Does this still reproduce for you, Ciprian?
Flags: needinfo?(ciprian.muresan)

Comment 5

a year ago
I am not the original poster, but the icon is still gone for me on current Win10 nightly build (20180327220126), in a new profile with light/dark theme and different densities checked.
Fwiw, icon for "Report Site Issue…" is gone too.
Build ID 	20180327220126
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

I am still able to reproduce this issue on Windows 10 x64, Arch Linux x64 (VM), Ubuntu 17.04 x64 (VM), Windows 7 x64 and an iMac late 2009 running 10.13.3.

I am unable to reproduce this issue on a MacBook Pro retina display running 10.13.3 or on Windows 7, 8, 10 with a 4K monitor. However on Ubuntu 14.04 and 16.04 on the same machine with the 4K monitor I can reproduce the issue. Maybe the problem is related to on board video cards, video drivers or lack thereof.

Updated summary to include the icon for "Report Site Issue...".
Flags: needinfo?(ciprian.muresan)
Summary: Screenshots item in the Page Actions menu no longer shows an icon on the latest Nightly → Screenshots and Report Site Issue... items in the Page Actions menu no longer show icons on the latest Nightly
This is bug 1449200.  I'll let you all mark it as a dupe if you want.  For now I'll mark it as a dependent.
Depends on: 1449200
No longer blocks: 1446250
Status: NEW → RESOLVED
Last Resolved: a year ago
No longer depends on: 1449200
Flags: needinfo?(kmaglione+bmo)
Flags: in-testsuite?
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1449200

Updated

11 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.