Closed Bug 1448070 Opened 2 years ago Closed 2 years ago

busted Linux and Windows opt builds when Gecko 61 merges to Beta on 2018-04-26

Categories

(Toolkit :: Add-ons Manager, defect, blocker)

defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 blocking verified

People

(Reporter: aryx, Assigned: aswan)

References

Details

Attachments

(3 files)

Like mentioned yesterday, the patches for bug 1446676 cause Linux and Windows opt builds of central-as-beta simulations to go bust. Bug 1446676 got backed out later yesterday for mass failing T-P-e10s for OS X nightlies. It relanded later and the build issue is back for the beta simulations.

Today's central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&revision=811e2ea438a88cb9e407f4ab66387bc2c18d0f35&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&group_state=expanded

Build log: https://treeherder.mozilla.org/logviewer.html#?job_id=169640968&repo=try

[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  rm -f jarlog/en-US.log
[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  make[1]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  make[1]: Entering directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  make[1]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  make[1]: Entering directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-03-22T12:31:33.417Z] 12:31:33     INFO -  make[1]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-03-22T13:11:33.457Z] 13:11:33     INFO - Automation Error: mozprocess timed out after 2400 seconds running ['/usr/bin/python2.7', 'mach', '--log-no-times', 'build', '-v']
[task 2018-03-22T13:11:33.479Z] 13:11:33    ERROR - timed out after 2400 seconds of no output
[task 2018-03-22T13:11:33.480Z] 13:11:33    ERROR - Return code: -15

This shall get fixed soon to prevent losing our beta 61 coverage.

FTR, yesterday's bisecting to identify the bug:

Last good: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1bca4bb60e9c074aeee4f1aefff196a76e2522cf
First bad: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ff89401a888803eda8fee7d54cbc7461b6e0aef4
Flags: needinfo?(kmaglione+bmo)
This blocks being able to do useful uplift simulations, upping the severity.
Severity: major → blocker
When I try to do a PGO build locally, what actually times out is the last rustc stage that builds gkrust. I suspect that's what's happening here, too. It doesn't look like it ever gets to the point of running Firefox.
Flags: needinfo?(kmaglione+bmo)
No, I take that back. It looks like I'm wrong, and the last version of the quitter extension was signed as a privileged extension.

It looks like aswan is the person who added that version, so I suppose he'll need to take care of signing the new one.
Flags: needinfo?(aswan)
See bug 1393162.  I'll try to take care of it later today if nobody beats me to it before then.
I attached a recent copy of quitter.xpi, with a stray call to removeObserver() removed, I'll include that in the final patch with the updated signed xpi.

Jason, can you sign this with "Mozilla Extensions", just like in bug 1393162?
Flags: needinfo?(aswan) → needinfo?(jthomas)
Flags: needinfo?(jthomas) → needinfo?(wezhou)
Attached file signed.8962066.xpi
Signed file attached. Please test.

Hi Andrew, did you know "Mozilla Extensions" aka Internal Extensions signing is now self service? If you often need to have this type of add-ons signed, please consider request access to sign them using the process here
https://mana.mozilla.org/wiki/display/FIREFOX/Internal+Extension+Signing.

Thanks!
Flags: needinfo?(wezhou)
Ryan, can you either point me to the latest simulated beta patch set or launch a test build with the attached patch?
Flags: needinfo?(ryanvm)
The bug summary doesn't say this but the issue is with PGO builds right?  That try job doesn't include pgo...
Flags: needinfo?(aryx.bugmail)
They're PGO by virtue of the in-tree config changes made by the simulation patches (same way it's done on "real" Beta/Release)
Flags: needinfo?(aryx.bugmail)
Attachment #8962447 - Flags: review?(kmaglione+bmo)
Comment on attachment 8962447 [details]
Bug 1448070 Sign quitter.xpi as privileged

https://reviewboard.mozilla.org/r/231292/#review236786

Thanks!
Attachment #8962447 - Flags: review?(kmaglione+bmo) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s f031c0efc040003e8443945a4680a21d85c19eaf -d 226c8c740c34: rebasing 454085:f031c0efc040 "Bug 1448070 Sign quitter.xpi as privileged r=kmag" (tip)
merging tools/quitter/bootstrap.js
merging tools/quitter/quitter@mozilla.org.xpi
warning: tools/quitter/quitter@mozilla.org.xpi looks like a binary file.
warning: conflicts while merging tools/quitter/quitter@mozilla.org.xpi! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cdc8f6ff1a88
Sign quitter.xpi as privileged r=kmag
https://hg.mozilla.org/mozilla-central/rev/cdc8f6ff1a88
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Assignee: nobody → aswan
You need to log in before you can comment on or make changes to this bug.