Closed Bug 1448301 Opened 2 years ago Closed 2 years ago

Tabstrip rendering errors

Categories

(Core :: Graphics, defect)

61 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 blocking verified

People

(Reporter: Tobias.Marty, Assigned: bas.schouten)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180323100142

Steps to reproduce:

Updated to Nightly 61.0a1 (2018-03-23) (64-bit) on Windows 10 16299.334. 


Actual results:

Tabstrip shows rendering errors like white areas, disappearing tab titles etc.

Bisection: 
2018-03-23T13:27:19: DEBUG : Found commit message:
Bug 1440753: Replace pixman regions with our own region code. r=mattwoodrow

MozReview-Commit-ID: KPsTAw3Uwa2
Attached image screensahot
I can reproduce the issue on Nightly 61.0a1 win10 64bit.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → bas
Status: NEW → ASSIGNED
This may also affect web content. When I select items on the web frontend of my e-mail service (mail.gmx.net) the items don't get visually highlighted anymore. Could be another regression though.
(In reply to TMart from comment #2)
> This may also affect web content. When I select items on the web frontend of
> my e-mail service (mail.gmx.net) the items don't get visually highlighted
> anymore. Could be another regression though.

I'm guessing this is probably from my patch as well, I'm trying to figure out if it's something simple through remote desktop now since I'm traveling, if I haven't gotten something in a couple of hours I should probably be backed out.
This must be the result of one of my last-minute fixes to issues found through try, since I only checked those with our automated tests and didn't extensively try the actual build locally. But this seems like a pretty serious issue.
Odd, I can't seem to reproduce this, I wonder if this is related to some kind of theme.
I'm using the default theme. All others are disabled.
My STR
1. Default theme
2. Open slightly large/complex page in multiple tabs 
3. Mouse hover over tabs/toolbutton while tab loading ping-pong are animating
Based on my experience, This occurs on:
- https://hangouts.google.com/ a lot, so I suggest it for testing
- Themer extension, and Quantum light extension
- Default Light theme too, but not on dark theme

PS. using FF nightly x64, on Windows 10

Duplicated in #1448304 and #1448333
I'm seeing it every time I open a link in a new foreground tab.  It doesn't happen if loading in existing or background tabs.  When the page finishes loading, the corruption generally goes away.

I'm using the standard Light theme.
(In reply to Abderrahim Digourdi from comment #8)
> - Default Light theme too, but not on dark theme

Happens on dark theme too
This was fixed by backout and fixed nightlies are available.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1448318
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.