Closed Bug 1448375 Opened 3 years ago Closed 3 years ago

Custom tabs launch an instance of Firefox on open

Categories

(Firefox for Android Graveyard :: Custom Tabs, defect)

Firefox 61
defect
Not set
normal

Tracking

(fennec?, firefox61 affected)

RESOLVED WORKSFORME
Tracking Status
fennec ? ---
firefox61 --- affected

People

(Reporter: ishitatsuyuki, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Android 7.0; Mobile; rv:61.0) Gecko/61.0 Firefox/61.0
Build ID: 20180323100124

Steps to reproduce:

Opening a page in custom tabs.

Also, PWA's are also suffering from this behavior. It launches, open a custom tab (which is already wrong), and then launch the main instance with the same URL (essentially loading thrice).


Actual results:

Apart from the normal custom tabs, a normal Firefox tab is loaded and brought to foreground immediately.


Expected results:

The custom tabs should load, without launching the main instance of Firefox.
I was able to reproduce this with Nexus 5(Android 6.0.1) and Huawei MediaPad M2 (Android 5.1.1). When a link is opened in custom tab, the same link is opened in browser. The issue is not reproducible on 60.0b7.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Can you run moz regression for this and find the range?
Flags: needinfo?(sorina.florean)
Regression range:

Last good build: 2018-03-20
First bad build: 2018-03-21
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bfb7edfd0436db388bb9e103b8ad817fc50bfdcf&tochange=e636edf00e6fbdc3206c9df4a1548ae38b3d13fa
Flags: needinfo?(sorina.florean)
Doesn't seem to happen on 20180328141007. ...fixed?
Can you confirm it was fixed?
Flags: needinfo?(ishitatsuyuki)
Yes this no longer happens anymore.
Flags: needinfo?(ishitatsuyuki)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.