Closed Bug 1448517 Opened 2 years ago Closed 2 years ago

Keyword searches with POST opensearch.xml engines first sends GET request and no POST request

Categories

(Firefox :: Search, defect, P1)

59 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1435615

People

(Reporter: aversa, Unassigned)

References

Details

(Whiteboard: [fxsearch])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180316162318

Steps to reproduce:

For search engines whose opensearch.xml file specifies a POST request (e.g., DuckDuckGo's: https://duckduckgo.com/opensearch.xml ), performing a keyword search (e.g., "d mysearch" in the address bar, if I've assigned "d" for DuckDuckGo's keyword) first sends a GET request, resulting in a blank search results page from the search engine. Performing "d mysearch" again sends a POST request.

Also, I get this same behavior in Safe Mode. It may have to do with my having recently specified "Firefox will never remember history."


Actual results:

GET request is sent first, and no POST request.


Expected results:

POST request should have been first request.
Summary: Keyword searches with POST opensearch.xml engines first sends GET request → Keyword searches with POST opensearch.xml engines first sends GET request and no POST request
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Also, this behavior only occurs when search is begun from a "about:blank" page (e.g., in a newly created tab).
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
20180315233128

(In reply to aversa from comment #0)
> For search engines whose opensearch.xml file specifies a POST request (e.g.,
> DuckDuckGo's: https://duckduckgo.com/opensearch.xml )

Please provide exact steps to reproduce the issue.

* The aforementioned search plug-in doesn't specify POST.
* The built-in DuckDuckGo search plug-in doesn't specify POST either.

If I do the following, then it works for me:
1. about:preferences#privacy - set "Firefox will: never remember history"
2. https://addons.mozilla.org/firefox/addon/duckduckgo-html/ [1] click the "Add to Firefox" button, check "Make this the current search engine" then click the "Add" button.
3. about:preferences#search - double-click the "Keyword" row next to "DuckDuckGo HTML", type d then press the Enter key.
4. Press F12 to bring up the developer tools, then click the Console tab. Make sure the "Requests" filter is enabled.
5. Into the location bar, type the following, then press the Enter key:
d mozilla firefox


[1] That's one of 2 official DuckDuckGo search plug-ins on AMO that use POST. The other one is "DuckDuckGo (Lite SSL)". There are others on the Mycroft Project site.
https://addons.mozilla.org/firefox/user/duckduckgo/
http://mycroftproject.com/search-engines.html?name=DuckDuckGo+POST
Has Regression Range: --- → irrelevant
Has STR: --- → no
Component: Untriaged → Search
Flags: needinfo?(aversa)
Keywords: steps-wanted
I think there's another bug about this...
Bug 1435615 is the bug I was thinking of, but it's not quite the same.  It doesn't involve keyword searches, so it's probably best not to dupe the two.  I bet they have the same underlying cause though.

I can reproduce this bug with:

1. New profile
2. Go to https://www.startpage.com/
3. Right-click the search box on that page, click Add a Keyword Search, complete the dialog with, for example, a keyword "s"
4. Restart
5. Open a new tab
6. Type "s test" in the location bar and hit enter

You get redirected to https://www.startpage.com/ instead of doing a search.
Status: UNCONFIRMED → NEW
Has STR: no → yes
Ever confirmed: true
Flags: needinfo?(aversa)
Keywords: steps-wanted
Priority: -- → P3
See Also: → 1435615
Whiteboard: [fxsearch]
This deserves to be higher than a P3 I think.
Priority: P3 → P1
(In reply to aversa from comment #6)
> I don't get this issue anymore with FF 59.0.2 (but did with 59.0.1).

Actually, the behavior is sporadic for me with FF 59.0.2… so this bug still applies to 59.0.2.
The patch in bug 1435615 fixes this.
I'll just mark this a duplicate of bug 1435615 since the underlying problem is the same.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435615
You need to log in before you can comment on or make changes to this bug.