Last Comment Bug 144853 - Respect lang attribute in HTML Rendering.
: Respect lang attribute in HTML Rendering.
Status: RESOLVED DUPLICATE of bug 16206
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Esben Mose Hansen
: Yuying Long
: Makoto Kato [:m_kato]
Mentors:
Depends on: Default-Quotes nested-quotes 35768
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 14:06 PDT by Karl Dubost
Modified: 2003-10-30 16:12 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Set of examples for using the lang attributes at the same time of the q element. (4.64 KB, text/html)
2002-05-15 21:44 PDT, Karl Dubost
no flags Details

Description Karl Dubost 2002-05-15 14:06:30 PDT
For example if you have a document which is in english

<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">

And you have defined locally another language, for example:

<blockquote lang="fr">
<p><q> Je n'ai dessein de relater, en marge du récit que je vais entreprendre,
que les épisodes les plus marquants de ma vie... </q></p>
<p>Nadja - André Breton</p>
</blockquote>

The double quote in french for a quote are not "blabla" but « blabla ».
Comment 1 Yuying Long 2002-05-15 16:11:52 PDT
I can not reproduce this on Mac OS X and WinXP - I saw the "" but not «» when I
defined the lang=fr in blockquote.

Could you please attach a test page or give a link to a web site that can see
the problem? thanks!
Comment 2 Karl Dubost 2002-05-15 21:44:36 PDT
Created attachment 83842 [details]
Set of examples for using the lang attributes at the same time of the q element.

The file is also accessible at
http://www.la-grange.net/2002/05/15-citation-lang.html
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2002-05-15 23:21:33 PDT
confirmed....
Comment 4 David Baron :dbaron: ⌚️UTC-10 2002-05-16 06:01:54 PDT
Seems to be a duplicate of bug 35768 and bug 24861, and perhaps bug 16206.
Comment 5 Roy Yokoyama 2002-05-21 11:00:30 PDT
assign to nhotta.
can you take a look at this?
Comment 6 Esben Mose Hansen 2002-06-24 01:28:09 PDT
After bug 24861 is fixed, fixing this bug is a matter of adding a style rule for
each language. There's a discusssion of this started by my in the .browser
newsgroup....
Comment 7 nhottanscp 2002-07-17 17:46:56 PDT
Reassign to shanjian.
Comment 8 Shanjian Li 2002-07-18 09:44:36 PDT
give it to esben. 
Comment 9 Esben Mose Hansen 2002-07-18 11:36:15 PDT
Accepting...
Comment 10 David Baron :dbaron: ⌚️UTC-10 2003-10-30 16:12:20 PST

*** This bug has been marked as a duplicate of 16206 ***

Note You need to log in before you can comment on or make changes to this bug.