No smoothing in SVG mask as circle

RESOLVED FIXED in Firefox 61

Status

()

defect
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: hololelouch, Assigned: lsalzman)

Tracking

({regression})

59 Branch
mozilla61
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 wontfix, firefox60 wontfix, firefox61 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

Posted image bug.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180315233128

Steps to reproduce:

Simple SVG mask as <circle>, or similar <path> displays as NOT smoothed
Check this code https://jsfiddle.net/2b4tgpq5/6/


Actual results:

Antialiasing with mask as circle or similar path dissapears


Expected results:

Should be some antialiasing. Check attached image to see how SHOULD BE
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b534147049e9a4afaa3320712d824dc9563ac67&tochange=7fb451a4d22c87e7de74be4c169c85601bdb938e

Regressed by: Bug 1359527
Blocks: 1359527
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
OS: Unspecified → Windows
Priority: -- → P3
Whiteboard: [gfx-noted]
Apparently PushLayer() is not liking the intermediate image generated by LuminanceToAlpha. The only workaround that seems to help is to use the ColorMatrix with specifically STRAIGHT alpha mode (PREMULTIPLIED alpha mode reproduces the bug).
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #8964653 - Flags: review?(jmuizelaar)
Comment on attachment 8964653 [details] [diff] [review]
use ColorMatrix effect instead of LuminanceToAlpha effect for DrawTargetD2D1::IntoLuminanceSourc

Review of attachment 8964653 [details] [diff] [review]:
-----------------------------------------------------------------

Bas should look at this instead.
Attachment #8964653 - Flags: review?(jmuizelaar) → review?(bas)
Attachment #8964653 - Flags: review?(bas) → review+
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/458c07cbe94b
use ColorMatrix effect instead of LuminanceToAlpha effect for DrawTargetD2D1::IntoLuminanceSource. r=bas
https://hg.mozilla.org/mozilla-central/rev/458c07cbe94b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1423213
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.