Profile creation window renders blank

VERIFIED FIXED

Status

defect
P3
blocker
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: dead, Assigned: gayatrib)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
When I start up Mozilla with no profile (rm -rf ~/.mozilla), the profile
creation window appears, with the button bars at the top and bottom of the
window, but the actual content area stays blank (gray).  This was working ok
yesterday, I believe.

Also, if you close the profile creation window (with the window manager),
apprunner goes ahead and starts... I suppose this is also a bug, but I'm not
sure.
Reporter

Updated

20 years ago
Severity: critical → blocker
Reporter

Comment 1

20 years ago
Pinkerton says it's a blocker.

Comment 2

20 years ago
The second part of your report is already covered by another bug.

Given that you get a profile and can start the app, what exactly makes this a
blocker?

Updated

20 years ago
Assignee: selmer → gayatrib

Comment 3

20 years ago
Gayatri, see if you can figure out where the problem is.  Best bet is something
changed underneath us again.  Steve
Reporter

Comment 4

20 years ago
You don't end up with a profile though, if you close the window to allow the
browser to continue to load.  The browser starts up with NO profile directory
created, which seems like it would cause problems in other areas.

You can't just click the Finish button, it says there is not enough information
filled in.
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Assignee

Comment 5

20 years ago
Working on it. Will update on the status soon.
Assignee

Comment 6

20 years ago
Adding Simon to cc list.
I managed to make it work by changing, in cpw.js:loadPage()

	if (!firstTime) {
		saveData();
	}

to

	if (firstTime == false) {
		saveData();
	}

for some reason, firstTime is undefined first time through.
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
This failure was because of a JS error. In cpw.js, there was this line:

var wizardMap = new Array("test-content1_1.xul");

which does not work. In fact, it fails, leaving the rest of the globals
uninitialized.

I changed this to

var wizardMap = ["test-content1_1.xul"];

and things work again.
Assignee

Comment 9

20 years ago
Thanks Simon! Cannot believe how simple js syntax keeps changing.
I was concentrating on hidden form elements, as that was where the
error seemed to be existing.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 10

20 years ago
build 199092208

Updated

20 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 11

20 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.